Domain showing wrong certificate

What had worked? I use Windows 2012, but never had such a problem.

Your certificate has only one domain name ( https://check-your-website.server-daten.de/?q=jdcounselling.co.uk ):

CN=www.jdcounselling.co.uk
	07.05.2019
	05.08.2019
expires in 81 days	www.jdcounselling.co.uk - 1 entry

So your non-www version isn’t secure.

Domainname Http-Status redirect Sec. G
http://jdcounselling.co.uk/
217.68.242.220 301 https://jdcounselling.co.uk/ 2.057 A
http://www.jdcounselling.co.uk/
217.68.242.220 301 https://www.jdcounselling.co.uk/ 1.857 A
https://jdcounselling.co.uk/
217.68.242.220 301 https://www.jdcounselling.co.uk/ 3.106 N
Certificate error: RemoteCertificateNameMismatch
https://www.jdcounselling.co.uk/
217.68.242.220 200 3.314 B

Create one certificate with both domain names and use that with two bindings.

Or create a second certificate with the non-www domain name and use that (I don’t know if your client has such options).

I removed the certificate for the other domain it was picking up, and it reverted to it’s own certificate. When I create a certificate it has in the past created a certificate for both the www, and the non www. domain names, I’m not sure how to create a certificate for just the non www. domain alias as they both currently point at the same certificate.

SHould I just remove the certificate and try again?

Regards
Pete

That’s

the better solution if your ACME-client you use support that.

So create one certificate with both domain names.

BTW, I’m still getting an error when the automated certificate renewal rins as in the screenshot.

Pete

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.