Domain name contains an invalid character from Azure

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: dänisheurlaub.de

I ran this command: Azure Let’s Encrypt site extension

It produced this output:

Fail to load resource from ‘https://acme-v02.api.letsencrypt.org/acme/finalize/73641585/3409210900’.

urn:ietf:params:acme:error:rejectedIdentifier: Error finalizing order :: Cannot issue for “dänisheurlaub.de”: Domain name contains an invalid character

My web server is (include version): Azure App service

The operating system my web server runs on is (include version): Azure

My hosting provider, if applicable, is: Azure

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Hi @jakobladingkaer

use the xn version:

xn--dnisheurlaub-gcb.de

“check-your-website” has a small converter. Insert dänisheurlaub.de, click one time. That doesn’t start the check, but converts the domain name to the xn-- version.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.