Domain Name change


#1

Hi,

I did make a domain name change for an existing domain (same name but different tld from .fr to .com) on the same IP, same machine, same server, same everything but the name. DNS is already propagated and ok, site with new name up and running, I tried to obtain new certs for the new domain but it’s like the system thinks I’m still on the old domain (see error below). I then erased the .well-known folder and all certs and re-generated self-signed certs, and then requested again Let’s Encrypt certr, same, still the same error like there is some kind of cache somewhere … any idea ?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: from la-fine-epicerie.fr to la-fine-epicerie.com

I ran this command: asking for cert

It produced this output:
ssl.CertificateError: hostname ‘www.la-fine-epicerie.com’ doesn’t match either of ‘la-fine-epicerie.fr’, ‘www.la-fine-epicerie.fr

My web server is (include version):Apache 2.4

The operating system my web server runs on is (include version): Debian 9

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Virtualmin/webmin

Pierre.


#2

It seems that your system does not recognize the new .com name - it still thinks it is named .fr
This is an internal setting.
Everything you mentioned that was changed is external.


#3

Hi
Thks for your input . But at the same time the website is working properly so for sure new name has been registered and Apache conf files are ok, I couldn’t find any reference to the old domain name.
And at the same time you are right, I’m pretty sure it’s an issue with Virtualmin, I already posted on their forums.
Thks again.
Pierre.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.