Domain - Invalid Response

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

beta-wellness.fitchek.com

I ran this command:

sudo certbot certonly --webroot --test-cert -w /opt/marketplace/public/wellness -d beta-wellness.fitchek.com

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for beta-wellness.fitchek.com
Using the webroot path /opt/marketplace/public/wellness for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. beta-wellness.fitchek.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://beta-wellness.fitchek.com/.well-known/acme-challenge/MxYYZeQc2V0sPtT61VpmICGeIwUThodb57t-jK7KEnE [2606:4700:30::681f:429d]: "\n\n<!–[if IE 7]> <html class="no-js "

IMPORTANT NOTES:

My web server is (include version):

nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version):

Ubuntu 18.04

My hosting provider, if applicable, is:

Cloudflare

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.31.0

The HTML is apparently a Cloudflare error page saying your origin web server is down.

Do you know what’s happening?

1 Like

Hi @Nate14

you use Cloudflare:

Host T IP-Address is auth. ∑ Queries ∑ Timeout
beta-wellness.fitchek.com A 104.31.66.157 yes 1 0
A 104.31.67.157 yes 1 0
AAAA 2606:4700:30::681f:429d yes
AAAA 2606:4700:30::681f:439d yes
www.beta-wellness.fitchek.com Name Error yes 1 0
CN=sni116869.cloudflaressl.com, OU=PositiveSSL Multi-Domain, OU=Domain Control Validated (3787)
	05.12.2018
	14.06.2019
expires in 73 days	sni116869.cloudflaressl.com, *.affairesingleslust.date, *.amsteelgroup.com, *.asianpornstar.me, *.assew.website, *.augmea.com, *.augmea.com.tr, *.basolin.site, *.bonustarjoukset.com, *.conexusforum.com, *.derbonusschatz.com, *.dvv-volleyball.de, *.fitchek.com, *.fuckamericangirls.com, *.furmitfur.date, *.gemroyaltie.com, *.gomonterey.com, *.guvard.xyz, *.housebuild.club, *.j-spbreviews.ml, *.kfo-boessner.de, *.longroad24.eu, *.mattloveskrissy.com, *.medik-plus.com, *.musicappiphone.club, *.seitesprungohnesichere.date, *.seitu.xyz, *.shopbuyby.com, *.slifkacenter.org, *.sportsbazar.pk, *.sward.xyz, *.swingervergleichfrauen.date, *.webcam-telefonsex.net, *.xn--bner-vna1l.de, affairesingleslust.date, amsteelgroup.com, asianpornstar.me, assew.website, augmea.com, augmea.com.tr, basolin.site, bonustarjoukset.com, conexusforum.com, derbonusschatz.com, dvv-volleyball.de, fitchek.com, fuckamericangirls.com, furmitfur.date, gemroyaltie.com, gomonterey.com, guvard.xyz, housebuild.club, j-spbreviews.ml, kfo-boessner.de, longroad24.eu, mattloveskrissy.com, medik-plus.com, musicappiphone.club, seitesprungohnesichere.date, seitu.xyz, shopbuyby.com, slifkacenter.org, sportsbazar.pk, sward.xyz, swingervergleichfrauen.date, webcam-telefonsex.net, xn--bner-vna1l.de - 67 entries

But with Cloudflare, you need an always running webserver with a correct certificate.

If your certificate is expired, you have the typical Cloudflare error messages:

Domainname Http-Status redirect Sec. G
http://beta-wellness.fitchek.com/
104.31.66.157 521 0.200 S
Origin Down
http://beta-wellness.fitchek.com/
104.31.67.157 521 0.184 S
Origin Down
http://beta-wellness.fitchek.com/
2606:4700:30::681f:429d 521 0.164 S
Origin Down
http://beta-wellness.fitchek.com/
2606:4700:30::681f:439d 521 0.153 S
Origin Down
https://beta-wellness.fitchek.com/
104.31.66.157 521 0.457 S
Origin Down
https://beta-wellness.fitchek.com/
104.31.67.157 521 0.390 S
Origin Down
https://beta-wellness.fitchek.com/
2606:4700:30::681f:429d 521 0.337 S
Origin Down
https://beta-wellness.fitchek.com/
2606:4700:30::681f:439d 521 0.294 S
Origin Down
http://beta-wellness.fitchek.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
104.31.66.157 521 0.176 S
Origin Down
Visible Content: Error 521 Ray ID: 4c141e7a3a08c2d3 &bull; 2019-04-02 16:18:30 UTC Web server is down You Browser Working Frankfurt Cloudflare Working beta-wellness.fitchek.com Host Error What happened? The web server is not returning a connection. As a result, the web page is not displaying. What can I do? If you are a visitor of this website: Please try again in a few minutes. If you are the owner of this website: Contact your hosting provider letting them know your web server is not responding. Additional troubleshooting information . Cloudflare Ray ID: 4c141e7a3a08c2d3 &bull; Your IP : 85.215.2.229 &bull; Performance &amp; security by Cloudflare
http://beta-wellness.fitchek.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
104.31.67.157 521 0.190 S
Origin Down
Visible Content: Error 521 Ray ID: 4c141e7b5efe63a3 &bull; 2019-04-02 16:18:30 UTC Web server is down You Browser Working Frankfurt Cloudflare Working beta-wellness.fitchek.com Host Error What happened? The web server is not returning a connection. As a result, the web page is not displaying. What can I do? If you are a visitor of this website: Please try again in a few minutes. If you are the owner of this website: Contact your hosting provider letting them know your web server is not responding. Additional troubleshooting information . Cloudflare Ray ID: 4c141e7b5efe63a3 &bull; Your IP : 85.215.2.229 &bull; Performance &amp; security by Cloudflare

(skipped the rest of the output).

So

  • use the Cloudflare integrated solution (or)
  • deactivate Cloudflare, create a new certificate, install it, then activate Cloudflare again

With activated Cloudflare, that can’t work.

PS: There is no older Letsencrypt certificate.

PPS: What’s the original ip address of your server? Test that ip direct.

My server is 174.117.43.114.

So here is the situation;

On cloudflare I have the A record created and set to gray cloud (DNS only)
ON cloudflare I have always use HTTPS turned off

the site I want to see up is beta-wellness.fitchek.com

On my server I have the sites-enabled and sites-available stuff set up correctly, and nginx is running with errors. I have the public folder where the site should point to created and populated with the app I want to serve.

The I run

sudo certbot certonly --webroot --test-cert -w /opt/marketplace/public/wellness -d beta-wellness.fitchek.com

And I get

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for beta-wellness.fitchek.com
Using the webroot path /opt/marketplace/public/wellness for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. beta-wellness.fitchek.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://beta-wellness.fitchek.com/.well-known/acme-challenge/sqqG3f6aBoqgtSGaJ16dvj2jrKDCkKE9IJgCqn6tC0U [174.117.43.114]: “\r\n404 Not Found\r\n<body bgcolor=“white”>\r\n

404 Not Found

\r\n

IMPORTANT NOTES:

It sounds like that’s not the correct web root, then.

What’s in Nginx’s error.log?

Why not use certbot --nginx or certbot certonly --nginx?

The webroot is definitely correct.

There is nothing in the access or error logs for nginx

I am anxious to run the command too many times and cause a lockout, so if you have suggestions for different parameters please let me know how they would be implemented.

Running it with --nginx seemed ot help:

sudo certbot --nginx -w /opt/marketplace/public/wellness -d beta-wellness.fitchek.com

It gave me two options

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.


1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you’re confident your site works on HTTPS. You can undo this
change by editing your web server’s configuration.


I chose #2, now waiting for everything to refresh, fingers crossed!

1 Like

--test-cert produces certificates that aren’t trusted by clients like browsers or Cloudflare’s CDN servers.

Moreover, certonly doesn’t configure Nginx to use the certificate, so Nginx might still be using something else.

Now this ip address in combination with your domain name beta-wellness.fitchek.com has a new Letsencrypt certificate ( https://check-your-website.server-daten.de/?q=174.117.43.114&h=beta-wellness.fitchek.com ):

CN=beta-wellness.fitchek.com
	02.04.2019
	01.07.2019
expires in 90 days	beta-wellness.fitchek.com - 1 entry

And checking your domain now it’s ok (Grade B).

Thank so much, you guys are awesome!

1 Like

thank you so much for your solution guys!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.