Invalid response from

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
test.dreamhome-solitaire.com
I ran this command:
sudo certbot --nginx
It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org

Which names would you like to activate HTTPS for?


1: test.dreamhome-solitaire.com


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for test.dreamhome-solitaire.com
Waiting for verification…
Challenge failed for domain test.dreamhome-solitaire.com
http-01 challenge for test.dreamhome-solitaire.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

My web server is (include version):
nginx version: nginx/1.16.0
The operating system my web server runs on is (include version):
CentOS Linux release 7.5.1804 (Core)
My hosting provider, if applicable, is:
N
I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.35.1
the /var/log/letsencrypt/letsencrypt.log validationRecord is:
“validationRecord”: [
{
“url”: “http://test.dreamhome-solitaire.com/.well-known/acme-challenge/wlF3RgTHS6754hltdYJ4TNdmHBLgP_leI3UdGxWDddQ”,
“hostname”: “test.dreamhome-solitaire.com”,
“port”: “80”,
“addressesResolved”: [
“35.237.208.138”,
“2600:1901:0:5f0f::”
],
“addressUsed”: “2600:1901:0:5f0f::”
}
]
my nginx config is:

server {
listen [::]:80;
listen 80;
server_name test.dreamhome-solitaire.com;

#charset koi8-r;
access_log  /var/log/nginx/host.access.log  main;

location / {
    root   /usr/share/nginx/html;
    index  index.html index.htm;
}

location /AppflyerNotify{
    proxy_set_header Host $host:$server_port;
    proxy_set_header X-Real-Ip $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_pass http://127.0.0.1:10013;
}

#error_page  404              /404.html;

# redirect server error pages to the static page /50x.html
#
error_page   500 502 503 504  /50x.html;
location = /50x.html {
    root   /usr/share/nginx/html;
}

# proxy the PHP scripts to Apache listening on 127.0.0.1:80
#
#location ~ \.php$ {
#    proxy_pass   http://127.0.0.1;
#}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
#location ~ \.php$ {
#    root           html;
#    fastcgi_pass   127.0.0.1:9000;
#    fastcgi_index  index.php;
#    fastcgi_param  SCRIPT_FILENAME  /scripts$fastcgi_script_name;
#    include        fastcgi_params;
#}

# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
#location ~ /\.ht {
#    deny  all;
#}

}

my /var/www dir is empty

Hi @hackerys

checking your domain there are Google-ip addresses - https://check-your-website.server-daten.de/?q=test.dreamhome-solitaire.com

Host T IP-Address is auth. ∑ Queries ∑ Timeout
test.dreamhome-solitaire.com A 35.237.208.138

Newark/New Jersey/United States (US) - Google LLC
Hostname: 138.208.237.35.bc.googleusercontent.com|yes|1|0|
||AAAA|2600:1901:0:5f0f::
Newark/New Jersey/United States (US) - Google LLC|yes||

What's the ip address of your system?

Checking your urls there are different answers:

Domainname Http-Status redirect Sec. G
http://test.dreamhome-solitaire.com/
35.237.208.138 200 0.220 H
http://test.dreamhome-solitaire.com/
2600:1901:0:5f0f:: 404 0.043 M
Not Found
https://test.dreamhome-solitaire.com/
35.237.208.138 -14 10.030 T
Timeout - The operation has timed out
https://test.dreamhome-solitaire.com/
2600:1901:0:5f0f:: -4 0.073 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. Authentication failed because the remote party has closed the transport stream.
http://test.dreamhome-solitaire.com:443/
35.237.208.138 -14 10.013 A
Timeout - The operation has timed out
Visible Content:
http://test.dreamhome-solitaire.com:443/
2600:1901:0:5f0f:: -8 0.084 A
ConnectionClosed - The underlying connection was closed: The connection was closed unexpectedly.
Visible Content:
http://test.dreamhome-solitaire.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
35.237.208.138 404 0.226 A
Not Found
Visible Content: 404 Not Found nginx/1.16.0
http://test.dreamhome-solitaire.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
2600:1901:0:5f0f:: 404 0.046 A
Not Found
Visible Content: Error 404 (Not Found)!!1 404. That’s an error. The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. That’s all we know.

/.well-known/acme-challenge - ipv4 is a standard-nginx - answer, ipv6 is a typical Google-answer.

Looks like your ipv6 doesn't work.

1 Like

Thank you very much for your reply. After I tried to close the ipv6 resolution of the domain name, the certbot command was successfully executed.:+1:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.