DNS-01 ISP Block port 80 guy [White flag]

I have a development project that I am doing the server hosting from Broadband connections. Yup, block 80 blocked. So DNS-01 is my only hope atm.

I am hosting DNS for these development servers and have Bind9(latest-centos-package).
I have more than 1 site with more than 1 server array with DNS and HTTP servers.

The applications use TLS and are working flawlessly.

However after trying certbot / and dehydrated and some others, I am wrapped around the axle.
I’m definitely waiving the white flag, can someone share a tutorial or a step by step that works for
Nginx and bind on DNS-01

Self-hosting DNS with BIND on your own just to be able to use DNS challenges for certs seems like way more trouble than it’s worth.

There are plenty of free and super cheap DNS hosting providers out there you could use.

Pick and migrate to one that fits your budget and works with your chosen client and you’ll have a much better time.

thanks @rmbolger I may… but I have global(dns) load balancing working on most these domains, and would never pay for a service like DNS… been in the game too long, and too stubborn. I’d buy a ssl cert before that haha…

Going to take a step back and then try again after dinner. Thanks

1 Like

We’d need to know exactly what you’ve already tried. With the exact commands used.

Also, your server setup is also important. Is there only one? Multiple? Virtual machines or just a single machine?

Further more, I’m moving your thread to the “Help” section, where you would have been provided with the following questionnaire. Please fill it in as wel as you can:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Ok, found an ISP that doesnt block 80, but ill need a dns-01 MOP.
I’ll post after I sleepa bit. 136am atm

You might check out acme-dns. Running that locally should be waaaay easier than getting this up and working through BIND.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.