My isp uses port 80 and i want to use certbot in port another port

i'm using nginx in a raspberry pi, i have a local isp that uses port 80 as managment port, when anybody tries to connect to my trough that port nothing happens, i talked to them and they say i need to use other port, anyone know how to make the authentication with other port? i also tried "sudo certbot certonly --webroot" and i got an error saying:
Error creating new order :: too many failed authorizations recently: see Failed Validation Limit - Let's Encrypt

i am not sure what to do know, i tried apache and nginx and nginx is the furthest i've come. all guides that i used except let's encrypt where made trough chat GPT.

Hello @wirytiox, welcome to the Let's Encrypt community. :slightly_smiling_face:

Only the HTTP-01 challenge of the Challenge Types - Let's Encrypt needs Port 80.
There are 2 other choices the DNS-01 challenge and the TLS-ALPN-01. Please read the Pros and Cons of each.

If you choose the DNS-01 challenge here is a list DNS providers who easily integrate with Let's Encrypt DNS validation

A list of some of the ACME Client Implementations - Let's Encrypt

There are other Free ACME CA Comparison - Posh-ACME

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Thank you for assisting us in helping YOU!

1 Like

The mod_md module for Apache can take care of much of the certificate trouble for the Apache webserver all by itself, no external ACME client required. And it seems it can also do the tls-alpn-01 challenge, see its documentation here: GitHub - icing/mod_md: Let's Encrypt (ACME) in Apache httpd, GitHub - icing/mod_md: Let's Encrypt (ACME) in Apache httpd and GitHub - icing/mod_md: Let's Encrypt (ACME) in Apache httpd


Thanks Osiris! That is a handy link indeed!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.