Deleting www fourth level domain from certificate with certbot

My domain is: elisasquicciarini.pietrobattiston.it

I ran this command:

sudo certbot certonly --cert-name elisasquicciarini.pietrobattiston.it -d www.elisasquicciarini.pietrobattiston.it

It produced this output:

You are updating certificate elisasquicciarini.pietrobattiston.it to include new
domain(s):
(None)

You are also removing previously included domain(s):
- elisasquicciarini.pietrobattiston.it

Did you intend to make this change?

My web server is (include version):

Apache2 2.4.38

The operating system my web server runs on is (include version):

debian buster

My hosting provider, if applicable, is:

gandi

I can login to a root shell on my machine (yes or no, or I don’t know):

yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.31.0

Notice that I would like to only remove the “www” fourth level domain (which does not work), but certbot proposes to remove the third level domain without “www”.

Hi @PBat

then your command is wrong. -d doesn’t mean delete, it means domain.

Your command says, you want a certificate with the same name, but only the www domain name. That’s not that what you want.

So change your command.

Oops. Thanks. I thought certbot was not smart enough for me, but the opposite was true. Replacing the domain name with the one without “www.” worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.