Creating certificate problem - Failed authorization procedure


#1

Hi everyone.
I have try to create SSL certifiate for blog, placed on VPS with ubuntu.
I has try to create certificate with many different ways, but every time i has got the same error message:

The following errors were reported by the server:

Domain: www.blog.mysitename.com
Type:   connection
 Detail: DNS problem: NXDOMAIN looking up A for
 www.blog.mysitename.com

 To fix these errors, please make sure that your domain name was
 entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you're using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

I don’t know, what i do wrong
Please, help me solve this problem.


#2

According to Let’s Encrypt, your hostname doesn’t exist. But without knowing the hostname, we can’t really debug further…


#3

Here is my host name
http://blog.jssolutionsdev.com/
It is works now, and it has publicly routable IP address.


#4

I try to create key for my host with www.
But it not works with www.hostname
I will try to fix it first. Thanks


#5

Probably the same problem as before: it doesn’t have a DNS record.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.