Could not obtain certificates: acme: error: 429

My domain is:

I ran this command: I have no direct access. Site is hosted on Shared hosting.

My web server is (include version): Apache

It has DirectAdmin control panel installed on it.
My hosting provider, if applicable, is: PhotonHosting

I can login to a root shell on my machine (yes or no, or I don't know): No

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): DirectAdmin

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I don't know

Getting below error. Even trying after 3 days, it throws same error.
2021/03/08 06:33:02 [INFO] [, *] acme: Obtaining SAN certificate
2021/03/08 06:33:02 Could not obtain certificates:
acme: error: 429 :: POST :: :: urn:ietf:params:acme:error:rateLimited :: Error creating new order :: too many new orders recently: see Rate Limits - Let's Encrypt - Free SSL/TLS Certificates, url:
Certificate generation failed.

Please help me.Thank You.

Where does that error come from? Somewhere in DirectAdmin?

There isn't any certificate issued for your hostname at present (, so it isn't a buggy client which is actually receiving a cert but failing to install it.

It seems your hosting provider is using a single account for their Let's Encrypt activities, as the "too many new orders recently" error corresponds with the " maximum of 300 New Orders per account per 3 hours" rate limit from the linked page in the error you've pasted.

That single account is actually recommended according to the integration guide of Let's Encrypt, so nothing wrong there.

However there might be some issue at your hosting provider. For example, a loop requesting orders very often for a hostname which is failing. So I would like to suggest for you to contact your hosting provider with your current problem. It's probably something only they can fix or make better.

On the other hand, you might get lucky if you try often enough, as the rate limit only has a three hour window. If you fail again and again, it might mean something is wrong at your hosting provider as I stated above.


@Osiris Thanks for answer. I have forwarded this answer to my hosting provider. They are working on it. Hope this will guide them solving this issue. Thank You.

1 Like

Everything sorted out @Vishal.CCBG123 ?

1 Like

Yes sir,
Thank you very much for the help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.