Could not issue a Let's Encrypt SSL/TLS certificate


My domain is hosting also email for some of my friends and clients.
I believe my self domain certificate has expired.
So I tried to use let's encrypt to make a new certificate. Probably too many times as I am totally lost in that domain.
I understand the error, but according to the FAQ, I can make up to 50 request per week. I don't think I made 50 request ever.
Do you know if I must do something to clear the limitation? Or I just need to wait?

All email send from Iphones are blocked. I believe it comes from a bad certificate on my domain.

Thanks a lot if soemone can help me.

Best regards,


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: Let's encrypt from Plesk

It produced this output:
Error: Could not issue a Let's Encrypt SSL/TLS certificate for .

One of the Let's Encrypt rate limits has been exceeded for .
See the related Knowledge Base article for details.

My web server is (include version): Plesk

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I don't know

Hi @123pierre

please read the document a little bit better.

These are subdomain limits. And you don't use a domain, you have a subdomain. Like a lot of other users. isn't on the public suffix list.

So it's wrong to use that domain name to create a certificate -> use your own domain.

Read the documentation.


@123pierre, because is very widely shared by OVH customers, it seems that you would be better off buying your own domain name and using it for your service (or else buying a paid certificate from a paid CA).

Alternatively, you could ask OVH to engage with Let's Encrypt to request a change in the rate limit applicable to this domain. But it seems like OVH must already be aware of this issue and perhaps it also prefers for people to buy their own domains when offering public services from an OVH VPS (and just use the subdomain for server administration purposes, like SSH and SFTP and so on).

1 Like

100% clear! Thanks a lot :wink:

1 Like

Crystal clear thanks :wink:

Fortunately there are other ACME-based issuers like Buypass or ZeroSSL that work with OVHcloud customer domains like or
if you really insist upon using them, considering those alternative issuers

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.