ContextualVersionConflict: botocore 1.12.92

I have an AWS EC2 instance running the AWS Linux 2 AMI.
I just installed certbot and the route53 dns:

sudo yum install certbot
sudo yum install certbot-dns-route53

Tried to exec:
sudo certbot certonly --dns-route53 -d … (my domain redacted)

Failure log:
2019-06-01 01:24:47,671:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
File “/bin/certbot”, line 9, in
load_entry_point(‘certbot==0.31.0’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python2.7/site-packages/certbot/main.py”, line 1335, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 206, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 52, in init
self.plugin_cls = entry_point.load()
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 2407, in load
self.require(*args, **kwargs)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 2430, in require
items = working_set.resolve(reqs, env, installer, extras=self.extras)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 875, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (botocore 1.12.92 (/usr/lib/python2.7/site-packages), Requirement.parse(‘botocore<1.6.0,>=1.5.0’), set([‘boto3’]))
2019-06-01 01:24:47,671:ERROR:certbot.log:An unexpected error occurred:

If I understand this, there is an issue with the botocore versions. Even if I’m right, I don’t have any sesne of how to resolve this failure.

Any help would be appreciated.

Hi,

I’ve digged around online and find the below solution (that might work, use at your own risk!):

Since this is an issue with certbot software, I strongly recommend you also open a ticket (before apply that solution) on certbot GitHub (although I guess this might only happen on a AWS EC2 instance with awscli installed).

Thank you

2 Likes

Thank you for finding this and responding so quickly. I will try it and see how it goes.

Thank you, stevenzhu! That worked fine and I have obtained my SSL certificate.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.