Doesn't match a supported version

I am on Amazon Linux, and am trying to update certs:

/usr/lib/python2.7/dist-packages/requests/ RequestsDependencyWarning: urllib3 (1.24.3) or chardet (3.0.4) doesn’t match a supported version!
Exiting abnormally:
Traceback (most recent call last):
File “/usr/bin/certbot”, line 11, in
File “/usr/lib/python2.7/dist-packages/certbot/”, line 1289, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/lib/python2.7/dist-packages/certbot/plugins/”, line 200, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/lib/python2.7/dist-packages/certbot/plugins/”, line 46, in init
self.plugin_cls = entry_point.load()
File “/usr/lib/python2.7/dist-packages/pkg_resources/”, line 2317, in load
self.require(*args, **kwargs)
File “/usr/lib/python2.7/dist-packages/pkg_resources/”, line 2340, in require
items = working_set.resolve(reqs, env, installer, extras=self.extras)
File “/usr/lib/python2.7/dist-packages/pkg_resources/”, line 779, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (urllib3 1.24.3 (/usr/lib/python2.7/dist-packages), Requirement.parse(‘urllib3<1.23,>=1.21.1’), set([‘requests’]))
Please see the logfile ‘/tmp/tmplu8Le_’ for more details.

1 Like

I am not sure what I should update to bring to correct versions.

1 Like


The version certbot required for urllib3 is between 1.12.1 and 1.23, your urllib version is 1.24.3, which is higher than the required version. So you probably need to downgrade or wait for certbot team to update their version.

Pinging @schoen @erica

Thank you

1 Like

Thank you! can you tell me how to downgrade urllib so that I can create certs in the meantime?

pip install urllib3==1.21.1

1 Like

Tracking this at

Thanks for the report!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.