RequestsDependencyWarning: urllib3 (1.13.1) or chardet (3.0.4) doesn't match a supported version!

Please fill out the fields below so we can help you better.

My domain is: rec.aplpackaging.co.uk

I ran this command: ‘letsencrypt renew’

It produced this output:
/usr/local/lib/python2.7/dist-packages/requests/init.py:80: RequestsDependencyWarning: urllib3 (1.13.1) or chardet (3.0.4) doesn’t match a supported version!
RequestsDependencyWarning)
Traceback (most recent call last):
File “/usr/bin/letsencrypt”, line 9, in
load_entry_point(‘letsencrypt==0.4.1’, ‘console_scripts’, ‘letsencrypt’)()
File “/usr/lib/python2.7/dist-packages/pkg_resources/init.py”, line 542, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/usr/lib/python2.7/dist-packages/pkg_resources/init.py”, line 2569, in load_entry_point
return ep.load()
File “/usr/lib/python2.7/dist-packages/pkg_resources/init.py”, line 2229, in load
return self.resolve()
File “/usr/lib/python2.7/dist-packages/pkg_resources/init.py”, line 2235, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 30, in
from letsencrypt import account
File “/usr/lib/python2.7/dist-packages/letsencrypt/account.py”, line 15, in
from acme import messages
File “/usr/lib/python2.7/dist-packages/acme/messages.py”, line 4, in
from acme import challenges
File “/usr/lib/python2.7/dist-packages/acme/challenges.py”, line 10, in
import requests
File “/usr/local/lib/python2.7/dist-packages/requests/init.py”, line 90, in
from urllib3.exceptions import DependencyWarning
ImportError: cannot import name DependencyWarning

My web server is (include version): nginx version: nginx/1.12.0

The operating system my web server runs on is (include version): Ubuntu 16.04.3 LTS

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Trying to fix this, I’ve added the latest PPA and updated to certbot.

I still get the error, however, it does then seem to run, despite the error:
/usr/local/lib/python2.7/dist-packages/requests/init.py:80: RequestsDependencyWarning: urllib3 (1.19.1) or chardet (3.0.4) doesn’t match a supported version!
RequestsDependencyWarning)
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Cert not yet due for renewal
Cert not yet due for renewal
Cert not yet due for renewal
Cert not yet due for renewal
Cert not yet due for renewal

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.