Config file problems


#1

Hi,

I am trying to setup the client with the config file in order to be able to run renewal from cron, and to say the least the documentation is quite incomplete. As seen in various post and tried, the location of the config file is NOT detected automatically, but that is solved easily.

My main problem lies with the options in the config file itself. I am trying to run the process for multiple domains and subdomains. My files looks like that so far:

# This is an example of the kind of things you can do in a configuration file.
# All flags used by the client can be configured here. Run Let's Encrypt with
# "--help" to learn more about the available options.

server = https://acme-v01.api.letsencrypt.org/directory

# Use a 4096 bit RSA key instead of 2048
rsa-key-size = 4096

# Uncomment and update to register with the specified e-mail address
email = user@mydomain.com

# Uncomment and update to generate certificates for the specified
# domains.
domains = mydomain.com, www.mydomain.com, mail.mydomain.com
domains = myseconddomain.com, www.secondmydomain.com
domains = sub.mythirddomain.net

# Uncomment to use a text interface instead of ncurses
text = True

# Uncomment to use the standalone authenticator on port 443
# authenticator = standalone
# standalone-supported-challenges = tls-sni-01

# Uncomment to use the webroot authenticator. Replace webroot-path with the
# path to the public_html / webroot folder being served by your web server.
# authenticator = webroot
# webroot-path = /usr/share/nginx/html

# Terms of Use. Accept LE terms of use: Default: False
agree-tos = True

# Flag for auto renewal. 
renew-by-default = True

What I was expecting was a non interactive event, but I still get requested to choose Easy Or Secure setup… And I was expecting to get 3 domain certificates. I only got 1… the last one.

What am I missing and/or doing wrong ?

I am running LE on Ubuntu server 14.04 LTS with Apache as a web server.

The command ran as follows:

./letsencrypt-auto --config /etc/letsencrypt/cli.ini

Thanks for your help.