Common name is vps123456ovh.net


#1

/opt/letsencrypt/letsencrypt-auto --version
letsencrypt 0.8.1

on centos 7

common name is vps123456ovh.net but my site is example.com

browser says: NET::ERR_CERT_AUTHORITY_INVALID

ssllabs.com says: Certificate name mismatch

heres the command I used: /opt/letsencrypt/letsencrypt-auto --apache -d example.com -d www.example.com


#2

And your question is… what exactly?

Besides, you’re giving us extremely few information to work with… Can’t help you, sorry…


#3

i thought that was pretty thorough :blush:

I thought it might be a bug related to https://github.com/certbot/certbot/issues/3094


#4

What’s your domain name ?


#5

removed.com (I’ll be removing the name from here later)


#6

It looks as if you have obtained 4 certificates over the last couple of days - but none of them are the one you are using in youe current apache config

Have you installed it in your apache, and reloaded apache ?


#7

Just did this:

to change the hostname permanently, you need to change it in two places:

vi /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=newHostName
and: a good idea if you have any applications that need to resolve the IP of the hostname)

vi /etc/hosts
127.0.0.1 newHostName
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
and then

rebooting the system

should I try the /opt/letsencrypt/letsencrypt-auto --apache -d example.com -d www.example.com command again?


#8

Why would you do that?

If the Apache configuration still isn’t sound, it should not matter what the hostname of your VPS is…


#9

cause for some reason they still said the hostname was vps123456ovh.net

(guessing)


#10

That’s because Apache is configured as such so it will provide some sort of self-signed certificate with that common name. What you really would like to do, is find out why your Apache isn’t providing the right certificate. (As @serverco tries to point you to).

Normally, certbot configures your Apache configuration for you, but perhaps something went wrong. So you should check the Apache configuration if it properly defines a VirtualHost section with the right ServerName/ServerAlias directive.


#11

/etc/httpd/httpd.conf ServerName and ServerAlias are commented out as per this tutorials instructions

Open the file /etc/httpd/conf/httpd.conf and search for the directives ServerName and ServerAlias. If they are set to the same domain you configured as a virtual host, you should comment them out by adding a # sign at the beginning of the line…


#12

And you did, per that tutorial, create a new “Virtual Host for your Domain”?


#13

yeah i did follow all the steps! My friend just helped me (he logged into sentora panel and did a bunch of stuff to the dns settings then he ran the letsencrypt auto again and its working now)

#magicFingers

thanks guys


#14

In the future, you might want to mention the use of panels such as Sentora.


#15

i will (did not think it was related)


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.