Command returns an empty label error

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: (also using)

I ran this command: # certbot certonly --standalone -d,

It produced this output: Requested domain is not a FQDN because it contains an empty label.

My web server is (include version): apache-2.4.57

The operating system my web server runs on is (include version): FreeBSD-13.2

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no - command line only

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): pkg install py39-certbot-apache-2.6.0

Try removing the space between your two domains:



  • use quotes around both names
    -d ","


  • use the -d twice:
    -d -d

removing the space after the comma solved the issue, thanks for the response


removing the space after the comma as suggested by "webprofusion" solved
the issue, thanks for the response


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.