Command failed: certbot certonly on omv5 with duckdns

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:nextcgdb.duckdns.org

I ran this command: ran this from Gui interface to set up ssl Cert

It produced this output: error in full - Error: Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-3" --agree-tos --authenticator webroot --email "graham.bell19@gmail.com" --preferred-challenges "dns,http" --domains "nextcgdb.duckdns.org"
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

at ChildProcess.exithandler (child_process.js:308:12)
at ChildProcess.emit (events.js:314:20)
at maybeClose (internal/child_process.js:1022:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)

when checked for error log could not find dir letsencript or file .log
path var/log/ does not contain letsencript

new to linux debian - so be kind

My web server is (include version):

The operating system my web server runs on is (include version):omv5

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using
Certbot):

Maybe you could find it if you replace the "i" with a "y" (letsencrypt).
OR
Let's try to find the LE log file, with:
find / -name letsencrypt.log

2 Likes

thanks for the quick response, I have found the file, saved to the shared folders created in the install here are the contents -

Regards
Graham

2021-11-24 11:31:56,613:DEBUG:certbot._internal.main:certbot version: 1.21.0
2021-11-24 11:31:56,614:DEBUG:certbot._internal.main:Location of certbot entry point: /usr/bin/certbot
2021-11-24 11:31:56,614:DEBUG:certbot._internal.main:Arguments: ['--non-interactive', '--quiet', '--config', '/etc/letsencrypt.ini', '--preferred-challenges', 'dns,http', '--disable-hook-validation']
2021-11-24 11:31:56,614:DEBUG:certbot._internal.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2021-11-24 11:31:56,669:DEBUG:certbot._internal.log:Root logging level set at 40
2021-11-24 11:31:56,671:DEBUG:certbot._internal.display.obj:Notifying user:


2021-11-24 11:31:56,671:DEBUG:certbot._internal.display.obj:Notifying user: No renewals were attempted.
2021-11-24 11:31:56,672:DEBUG:certbot._internal.display.obj:Notifying user: - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
2021-11-24 11:31:56,672:DEBUG:certbot._internal.renewal:no renewal failures

1 Like

This is good:

The log file doesn't include anything "useful".
[maybe removing the "--quiet / -q" would show more]

What shows?:
certbot certificates

1 Like

Hi

When I typed in certbot certificates nothing was found

root@TENBY6SERVER:~# -bash: certbot: command not found

-bash: -bash:: command not found

I have tried to find certbot but drawn a blank, but as mentioned I am a novice with Linux and find he file structure a bit confusing much more familiar with a windows environment.

Have done some research if I understand this correctly, certbot needs to be re installed if running Debian 10 – is this correct ?

see https://blog.wturrell.co.uk/letsencrypt-using-cerbot-with-snap-on-debian-10/

I am trying to install nextcloud on my OMV server using portainer stack. I have the following running,

Nginx-proxy-manager Nextcloud mariabd duckdns

when I try to configure Nginx by adding a SSL certificate I get the error

System Information

Linux

root@TENBY6SERVER:~# uname -srm

Linux 5.10.0-0.bpo.9-amd64 x86_64

Debian

root@TENBY6SERVER:~# cat /etc/os-release

PRETTY_NAME="Debian GNU/Linux 10 (buster)"

NAME="Debian GNU/Linux"

VERSION_ID="10"

VERSION="10 (buster)"

VERSION_CODENAME=buster

ID=debian

OMV5

Version 5.6.19-1 (Ursul)

Docker 5:20.10.10~3-0~debian-buster

Portainer 2.9.2

Regards

Graham

Try finding certbot with:
find / -name certbot

1 Like

Cheers

Result great what next ….

Highlighted refers to a previous attempt to set this up

root@TENBY6SERVER:~#

root@TENBY6SERVER:~# find / -name certbot

/srv/dev-disk-by-uuid-778866f8-7f10-4115-a732-425f9056f52c/appdata/docker/overlay2/7dfe63b3047f2295e3423f4c1f63c43485d153d1efcac5314d05e7930414f997/diff/usr/lib/python3.8/site-packages/certbot

/srv/dev-disk-by-uuid-778866f8-7f10-4115-a732-425f9056f52c/appdata/docker/overlay2/7dfe63b3047f2295e3423f4c1f63c43485d153d1efcac5314d05e7930414f997/diff/usr/bin/certbot

/srv/dev-disk-by-uuid-778866f8-7f10-4115-a732-425f9056f52c/appdata/docker/overlay2/8cedc02142b25b9f4447931b76e2f955152f972b99837cea033e3a81968c8281/diff/usr/lib/python3.8/site-packages/certbot

/srv/dev-disk-by-uuid-778866f8-7f10-4115-a732-425f9056f52c/appdata/docker/overlay2/8cedc02142b25b9f4447931b76e2f955152f972b99837cea033e3a81968c8281/diff/usr/bin/certbot

/srv/dev-disk-by-uuid-778866f8-7f10-4115-a732-425f9056f52c/appdata/docker/overlay2/8cedc02142b25b9f4447931b76e2f955152f972b99837cea033e3a81968c8281/merged/usr/lib/python3.8/site-packages/certbot

/srv/dev-disk-by-uuid-778866f8-7f10-4115-a732-425f9056f52c/appdata/docker/overlay2/8cedc02142b25b9f4447931b76e2f955152f972b99837cea033e3a81968c8281/merged/usr/bin/certbot

/ - /srv/dev-disk-by-label-Raid1/appdata/docker/overlay2/5cf621dbb3549b45050ccf61c2633851759f0e5996384ad663c52989af04acca/diff/usr/lib/python3.8/site-packages/certbot

/ - /srv/dev-disk-by-label-Raid1/appdata/docker/overlay2/5cf621dbb3549b45050ccf61c2633851759f0e5996384ad663c52989af04acca/diff/usr/bin/certbot

find: ‘/proc/18663/task/18663/net’: Invalid argument

find: ‘/proc/18663/net’: Invalid argument

find: ‘/proc/18664/task/18664/net’: Invalid argument

find: ‘/proc/18664/net’: Invalid argument

find: ‘/proc/18665/task/18665/net’: Invalid argument

find: ‘/proc/18665/net’: Invalid argument

find: ‘/proc/18666/task/18666/net’: Invalid argument

find: ‘/proc/18666/net’: Invalid argument

/var/lib/docker/overlay2/c0af8bb4f5bc57279ddbdc48df7bed770d2425d55e6ba4eb03aac5fe451a1e2e/diff/usr/lib/python3.8/site-packages/certbot

/var/lib/docker/overlay2/c0af8bb4f5bc57279ddbdc48df7bed770d2425d55e6ba4eb03aac5fe451a1e2e/diff/usr/bin/certbot

Graham

What say?:

/usr/bin/certbot --version
/usr/bin/certbot certificates

/snap/bin/certbot --version
/snap/bin/certbot certificates

1 Like

Hi Rudy

Not sure what you are requesting however I have done the following Using Win SCP to find the following

/srv/dev-disk-by-uuid-778866f8-7f10-4115-a732-425f9056f52c/appdata/docker/overlay2/7dfe63b3047f2295e3423f4c1f63c43485d153d1efcac5314d05e7930414f997/diff/usr/bin/certbot - Certbot attached

Putty log attached for what I assume you wanted me to find these

/usr/bin/certbot --version
/usr/bin/certbot certificates

/snap/bin/certbot --version
/snap/bin/certbot certificates Regards

Regards

Graham

(Attachment putty.log is missing)

(Attachment certbot is missing)

I don't see any logs :frowning:
Try just getting a screenshot of the outputs.

1 Like

Well tell me exactly what I need to input to get the outputs you need,

Login using an SSH client (like PuTTY).
[then execute all those commands - using sudo (if needed)]

1 Like

I get that, what I need I need are the commands please !

1 Like

These are the four commands:

2 Likes

Hi Rudy

Attached file for the entries below, something not right?

I feel you are not telling me the complete command surely this should be preceded with something. No such file or directory when entered exactly as you have shown,.

So tired tried preceding with find and got better results - you need to be clear what I need to enter - rubbish in = rubbish out !!!!

Still not sure this is what you are after.

Graham

puttylog1.txt (2.97 KB)

@rg305 Note that this seems to be a nginx-proxy-manager instance running in a Docker container.

Personally, I'm not burning my hands on either of those, so you're on your own :grimacing:

1 Like

OK, that would explain a lot.

So can you help ???

Sorry, I'm no Docker expert.

Does this screenshot help in any way

Graham