LetsEncrypt error

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: duckdns

I ran this command: certbot certonly

It produced this output:

  • The following errors were reported by the server:

    Domain: rsvcloud.duckdns.org
    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.
    My web server is (include version): OpenMediaVault 5

The operating system my web server runs on is (include version): Debian 9

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

1 Like


According to network tests, your port 443 and 80 are both filtered. This means there’s either a firewall blocking such ports, a router that didn’t forward correctly or your ISP blocked it.
Please check your firewall and port forwarding first.

Thank you


Ok . So , on my router both 80 and 443 are forwarded TCP/UDP .
Still, indeed , ports are seen close by any of the test i’ve done.

No firewall is set on my router , no firewall is there on my server …

My ISP is Virgin Media UK , they dont block ports as far as I know …
So where can be the issue ?

1 Like

I would suggest first test your server insider your home network.
Try to view your webpage with the internal IP of that server.

Sometimes, it’s also possible that the internal IP changed, so please double-check that IP.

Also, try to check the current external IP from your server. (curl whatismyip.akamai.com )

I can’t think of any other circumstances…

1 Like

My goal here is to access files on my server remotely.
So I did setup nexcloud and it is up and running.
From my local LAN I can start through a web browser the Nexcloud UI , I can see files , etc.

Server IP , public IP , all checked and ok.

Nextcloud should work remotely through duckdns DDNS / letsencrypt.
But because letsencrypt doent work , my files are not visible outside my local LAN.

1 Like

Let’s Encrypt is trying to check via HTTP on port 80. That doesn’t work from outside your LAN, and it needs to work properly before Let’s Encrypt can complete this test.

1 Like

I am aware of that.
As you can see , on my Hub 3.0 Virgin router , ports 80 and 443 are forwarded .
No idea why doesnt work though …

Here is the error when I try to apply letsecncrypt on NexcoudPi controil panel

Basically ALL my ports seemed to be closed … including 80 and 443

Plex and transmission working normally. (plex can be accesses outside LAN)
nextcloudpi docker running as well.

Ok . So did reset the router .
Again forwarded ports 80 and 443.

I’ve read that on Virgin Hub 3.0 router , you have to have the Firewall on in order to actually make port forwarding work.

So enabled firewall. As a result , at last , port 80 was open … but not the 443…
Tried again to enable letsencrypt … same error .

That did make a difference, from what I can see. You currently have a redirection rule that redirects everything from http://rsvcloud.duckdns.org/ to the corresponding URL on https://rsvcloud.duckdns.org/, which means that the HTTPS service would need to be available too in order to complete the validation process. Or you would need to make an exception so that /.well-known/acme-challenge is excluded from this redirection rule.

Oh , thanks .
Can you explain a bit how do I do one of those

Or the other one


What kind of web server are you using?

OpenMediaVault 5

Thanks. I’m not familiar with OpenMediaVault, so perhaps you can see if anyone else here can help you with that, or try over on their forum:


(Your question is on topic here and we’re happy to try to help with it, but we might not have as many people familiar with that software.)

Based on the timeouts on port 443, it’s possible or even likely that the biggest problem is still with your firewall or port forwarding, though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.