Change ip and certificate is disabled


#1

hello.
My IP server has changed and now my domain does not have ssl
I studied this topic but didn’t help .
More than 24 hours of IP change, but the domain is invalid

please help me.


#2

Certificates are not bound to IP addresses. Please show the affected domain name.


#3

thank you , this domain is


#4

When you changed the IP address, did you also change servers or hosting providers? In this case it seems that the server isn’t listening to connections on port 443 at all.


#5

yes , domain with “http” is up but with “https” can not open


#6

Hi,

It seems that you’ve moved to a new server / vps.
Please either :
enable / open port 443 and set hosting to listen to https.
Or contact your hosting provider to help (might incur extra charge)

You could also try to search on internet and see what you can do.

Thank you


#7

I didn’t understand whether you

  • changed only the IP address on an existing server

  • moved to a new server

  • moved to a different hosting provider

Can you explain more about what the change was?

As @stevenzhu says, you might need to tell your server to listen on port 443, or you might need your hosting provider to help open port 443, for example on a firewall.


#9

Thank you all
I got help from the hosting company manager.
He solved my problem somewhat, but still not active ssl.

my website

====================
My new problem is : Secure Connection Failed


#10

What kind of web server and hosting environment are you using?


#11

i use with lamp
linux(ubuntu)


#12

Did you write your own Apache configuration? Is there an HTTPS virtual host in your Apache configuration?


#13

I do not understand your point
Is it not automatically done?


#14

What Certbot command did you run? If you used certonly, then no, it’s not!


#15

Port 443 is now open !!

But ssl does not work properly

This is my new problem; what to do?

Please help me.


#16

Hi,

It seems that you changed your port 80 to 443, instead of add a listen.
Your http version is not working now.

Please fill in this form so we can help you better…

Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

Thank you


#17

My domain is: www.birmedia.ir

I ran this command:my ip server changed (I did not execute any command)

It produced this output:https faild

My web server is (include version):apache2

The operating system my web server runs on is (include version): Ubuntu 16

My hosting provider, if applicable, is: http://lasterloc.com/

I can login to a root shell on my machine (yes or no, or I don’t know):yes, i can access to root

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no i have not control panel


#18

Hi,

Can you run this command?
apache2ctl -S or apachectl -S (This will show your vhost config file)

Thank you


#19


#21

Can can you share the config file at /etc/apache2/sites-enabled/000-default-le-ssl.conf ?

Also i personally suggest you to use your own vHost file than the vHost certbot generated.

Thank you


#22