Certsage with IIS - This page isn’t working

I have installed certsage in the home directory > httpdocs directory of my site at simplyquality.org When I run https://simplyquality.org/certsage.php on safari I get no response. When I run it on chrome I get "This page isn't working ..."

How can I get certsage to execute on this site? Thanks

My domain is: simplyquality.org

I ran this command:https://simplyquality.org/certsage.php

It produced this output: This page isn’t working ; simplyquality.org is currently unable to handle this request.

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:GoDaddy

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):Plesk

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certsage 1.4.0

1 Like

Have you configured your IIS server to handle php scripts? I don't know IIS / PHP at all but I see an HTTP error 500 trying to run certsage. And, google shows me the blog below.

But, why do you need a cert now? Your IIS server is using a perfectly good cert you got on Jun14 just a month ago. Usually certs are renewed every 60 days.

Did you use certsage for the current cert? If not, why do you think you need to now?


Thanks for this. I want to use certsage because it makes it easy to renew the certificate. It was difficult (for me) to obtain and install the present certificate and I want to be able to use certsage on all of my sites so that the renewal process is uniform for all my sites.


If you have a lot of sites it is too bad you can't find an automated way to renew your certs.

Automating renewals is a key benefit of ACME and Let's Encrypt


Hello again, Leland :slightly_smiling_face:

While I'm honored that you wish to use CertSage across your enterprise, at present CertSage is not equipped with an installer for IIS, meaning that CertSage can acquire a certificate from Let's Encrypt for usage in IIS (once the IIS error when serving CertSage has been resolved), but you will need to install the acquired certificate by other means.

Assuming that your operating system for this server is Windows, I'm going to ping a couple of experts in this area to assist. They will possibly be able to offer you a better solution for Windows and IIS than CertSage can provide.

@webprofusion @rmbolger


If Plesk is ultimately the control panel managing the site, wouldn't the native Let's Encrypt extension be the easiest path forward?


Agree with @rmbolger that the official plesk extension should be easiest but I haven't used that and I have no idea how it behaves when used with other certificate tools.

For general IIS sites you can optionally use Certify The Web https://certifytheweb.com as follows (Requesting a Certificate | Certify The Web Docs) :

  • check IIS has your http bindings with hostname set to match your domain (it probably does): IIS Manage > Site > Bindings
  • In Certify The Web select New Certificate, select your IIS site, your domains (read from your IIS bindings) should be shown, if not check your bindings have names set in IIS.
  • Click Request Certificate, if that all works OK you should now have an automatically renewed https binding for each corresponding http binding you had originally.

If you're sticking with Certsage (which you've already had success with) you need to figure out the reason for the 500 error, this is likely caused by something in your configuration (see the link posted by @MikeMcQ ), I'd start by turning on error output.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.