Certs intsalled OK, but webserver fails can't find error message

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
Enable SSL & fetch certs from LE via Virtualmin
It produced this output:
This site can’t be reachedwww.acephonegames.com unexpectedly closed the connection.
My web server is (include version):
The operating system my web server runs on is (include version):
Ubuntu 20.04.2 LTS
My hosting provider, if applicable, is:
I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
Virtualmin 6.16
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

It's acting like there's something else hogging 443.
Also, there are no errors in the apache logs. If there were SSL errors on the system where would I look please?
The plain HTTP version works ok, it https://www.acephonegames.com that's failing.

1 Like

It this on shared hosting?
Are you the only admin of this system?
[if not, have you asked for help from prgmr.com?]
Are there any HTTPS sites that work(ed) on this system?

1 Like

This is a server I rent, and there are other hosts there none of which work!
Its actually one I'm setting up because I'm migrating from another server.
prgmr dont support this kind of probem.
I am only admin.
Thanks for reply.

1 Like

The webserver is properly and horrorbly misconfigured. It answers with HTTP on port 443. See for an example: http://acephonegames.com:443/

Notice the http:// without the s and :443, the port usually for HTTPS.

So Apaches configuration is completely wrong.


I am running the migration wizard which imports hosts directly from one physical machine to another. It must have screwed up.

Yes indeed,I found it. For some reason just one of these had totally borked everything this way.


It works now, indeed. The only thing left now is a HTTP to HTTPS redirect :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.