Certs could not be renewed 404

My domain is: wallet.myhush.org

I ran this command: sudo ./letsencrypt-auto renew

It produced this output:

2019-07-08 00:26:03,553:DEBUG:certbot.main:certbot version: 0.35.1

2019-07-08 00:26:03,867:INFO:certbot.main:Renewing an existing certificate
2019-07-08 00:26:04,044:DEBUG:certbot.crypto_util:Generating key (2048 bits): /etc/letsencrypt/keys/0063_key-certbot.pem

2019-07-08 00:26:04,213:DEBUG:acme.client:JWS payload:
“identifiers”: [
“type”: “dns”,
“value”: “wallet.myhush.org
2019-07-08 00:26:04,216:DEBUG:acme.client:Sending POST request to https://acme-v02.api.letsencrypt.org/acme/new-order:

Expires: Sun, 07 Jul 2019 22:26:04 GMT

“type”: “tls-alpn-01”,
“status”: “invalid”,
“url”: “https://acme-v02.api.letsencrypt.org/acme/challenge/5gGZZW6h71ATUWZSPnnv0GelPEnUnVYpITLIGpLM7Q8/17989604645”,
“token”: “nyO6MRZQkVEm0TWhDEERHDFqL0Sz6W5Jbj5ACbz0EpA”
“type”: “http-01”,
“status”: “invalid”,
“error”: {
“type”: “urn:ietf:params:acme:error:unauthorized”,
“detail”: “Invalid response from http://wallet.myhush.org/.well-known/acme-challenge/DK4P54Sb7RhLiCaJM_w_DGfPdVqYjV5Llir5otCh0Qg [2606:4700:30::681f:5d71]: “\u003chtml\u003e\n\u003chead\u003e\u003ctitle\u003e404 Not Found\u003c/title\u003e\u003c/head\u003e\n\u003cbody bgcolor=\“white\”\u003e\n\u003ccenter\u003e\u003ch1\u003e404 Not Found\u003c/h1\u003e\u003c/center\u003e\n\u003chr\u003e\u003ccenter\u003engin””,
“status”: 403
“url”: “https://acme-v02.api.letsencrypt.org/acme/challenge/5gGZZW6h71ATUWZSPnnv0GelPEnUnVYpITLIGpLM7Q8/17989604646”,
“token”: “DK4P54Sb7RhLiCaJM_w_DGfPdVqYjV5Llir5otCh0Qg”,
“validationRecord”: [
“url”: “http://wallet.myhush.org/.well-known/acme-challenge/DK4P54Sb7RhLiCaJM_w_DGfPdVqYjV5Llir5otCh0Qg”,
“hostname”: “wallet.myhush.org”,
“port”: “80”,
“addressesResolved”: [
> “2606:4700:30::681f:5d71”,
> "2606:4700:30::681f:5c71"
“addressUsed”: “2606:4700:30::681f:5d71”
2019-07-08 00:26:05,991:DEBUG:acme.client:Storing nonce: Sj1Vvy2ViKEsOsadO1kuhOUxwVNFhL1HI2Ctejnp7Rc
2019-07-08 00:26:05,991:WARNING:certbot.auth_handler:Challenge failed for domain wallet.myhush.org
2019-07-08 00:26:05,991:INFO:certbot.auth_handler:http-01 challenge for wallet.myhush.org
2019-07-08 00:26:05,992:DEBUG:certbot.reporter:Reporting to user: The following errors were reported by the server:

Domain: wallet.myhush.org
Type: unauthorized
Detail: Invalid response from http://wallet.myhush.org/.well-known/acme-challenge/DK4P54Sb7RhLiCaJM_w_DGfPdVqYjV5Llir5otCh0Qg [2606:4700:30::681f:5d71]: “\n404 Not Found\n<body bgcolor=“white”>\n

404 Not Found


To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address.
2019-07-08 00:26:05,992:DEBUG:certbot.error_handler:Encountered exception:
Traceback (most recent call last):
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/auth_handler.py”, line 90, in handle_authorizations
self._poll_authorizations(authzrs, max_retries, best_effort)
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/auth_handler.py”, line 154, in _poll_authorizations
raise errors.AuthorizationError(‘Some challenges have failed.’)
AuthorizationError: Some challenges have failed.

2019-07-08 00:26:05,992:DEBUG:certbot.error_handler:Calling registered functions
2019-07-08 00:26:05,992:INFO:certbot.auth_handler:Cleaning up challenges
2019-07-08 00:26:05,992:DEBUG:certbot.plugins.webroot:Removing /tmp/.well-known/acme-challenge/DK4P54Sb7RhLiCaJM_w_DGfPdVqYjV5Llir5otCh0Qg
2019-07-08 00:26:05,993:DEBUG:certbot.plugins.webroot:All challenges cleaned up
2019-07-08 00:26:05,993:WARNING:certbot.renewal:Attempting to renew cert (wallet.myhush.org) from /etc/letsencrypt/renewal/wallet.myhush.org.conf produced an unexpected error: Some challenges have failed… Skipping.

raise errors.AuthorizationError(‘Some challenges have failed.’)
AuthorizationError: Some challenges have failed.

2019-07-08 00:26:05,994:ERROR:certbot.renewal:All renewal attempts failed. The following certs could not be renewed:
2019-07-08 00:26:05,994:ERROR:certbot.renewal: /etc/letsencrypt/live/wallet.myhush.org/fullchain.pem (failure)
Error: 1 renew failure(s), 0 parse failure(s)

My web server is (include version): nginx/1.14.0

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: contabo

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.35.1

I tried a lot of research but I could not find the solution.
I can not renew my certificate that ends today.
I created a file in the ‘acme-challenge’ folder at this address:
It is easily accessible from a browser.

I have the impression that there is an automatic redirection http -> https that blocks the renewal.

Here is some of my config nginx :

server {
listen 80;
listen [::]:80;

server_name wallet.myhush.org;

root /var/www/wallet.myhush.org;
index index.html;

#include nginxconfig.io/letsencrypt.conf;
location /.well-known/acme-challenge/ {
allow all;
root /var/www/wallet.myhush.org;

location / {

return 301 https://wallet.myhush.org$request_uri;


access_log /var/log/nginx/myhushwallet80.access.log;

error_log /var/log/nginx/myhushwallet80.error.log;


Could you give me a track to fix this malfunction?

Best regards


It's not being redirected to HTTPS, but

It looks like Certbot is configured to save the file in the wrong directory.

You can fix that by running a Certbot command similar to the one used to create the certificate originally, possibly by running "sudo ./certbot-auto renew -w /var/www/wallet.myhush.org", or by editing /etc/letsencrypt/renewal/wallet.myhush.org.conf.


Many thanks @mnordhoff.
I edit


and now it’s work.

Congratulations, all renewals succeeded. The following certs have been renewed


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.