Certonly "enter a webroot"


#1

I’m attempting to move from StartSSL to Let’s Encrypt. It went fine on one webserver with all of the auto setup on Ubuntu 16.04. I’m now moving to another Apache instance that has a more complicated setup. The auto setup kicked me out and told me to use the certonly routine. In doing that, I’m stuck at the line to enter the webroot. What does it expect here? I’m assuming the local path, the DocumentRoot in the conf files? IE /var/www/mysite.com/? I’ve attempted every variant of this and I keep getting the Invalid Input message. I found a bug that suggested the terminal size needed to be larger. I’m currently running it at 280x70, so I don’t think that’s the issue.

Thanks!

Please fill out the fields below so we can help you better.

I ran this command:
./certbot-auto certonly

My operating system is (include version):
Ubunut 14.04
My web server is (include version):
Apache2

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes.


#2

Is this at the prompt that says:

Press 1 [enter] to confirm the selection (press 'c' to cancel): 

If so, type 1 and press Enter. Then enter your DocumentRoot.

You can also pass the options through the command line, if you prefer. For example:

./certbot-auto certonly --webroot -w /var/www/mysite.com -d mysite.com

Webroot - Invalid input
#3

Oh geez. I thought it was echoing out “1” because I had selected option 1 (Place Files in a Webroot) and it was asking for the webroot location at that prompt.

Thanks!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.