Opensuse 13.1, apache 2.4 --- cert create error


#1

Get the following error

Requesting root privileges to run letsencrypt…
/root/.local/share/letsencrypt/bin/letsencrypt certonly -c /etc/letsencrypt/cli.ini
Directory ‘/etc/apache2/sites-enabled’ does not exist. Please ensure that the values for --apache-handle-sites and --apache-server-root are correct for your environment.

The default path does not exit in opensuse. Is there a way to override the path in config?


#2

certonly shouldn’t care about your apache configuration - rather, it can be used with the standalone, webroot or manual plugin.

Could you provide your /etc/letsencrypt/cli.ini? I suspect that something in there might be overwriting the certonly verb.


#3

I also tried
letsencrypt-auto --apache

It gave me the same error.

This is my cli.ini

rsa-key-size = 4096
email = webmaster@.com
authenticator = apache
webroot-path = /srv/www/htdocs
domain = .com, www..com


#4

This line will make the client use the apache authenticator. You’re using webroot-path, so I’m assuming you’ll want to use the webroot authenticator instead.

Take a look at the webroot documentation for more details.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.