Certificate with a CNAME-only domain?

My domain is: nextcloud.redkonflict.com

I ran this command:

  1. certbot --apache
  2. certbot -d nextcloud.redkonflict.com --webroot certonly

It produced this output:
- The following errors were reported by the server:

** Domain: nextcloud.redkonflict.com**
** Type: dns**
** Detail: DNS problem: query timed out looking up A for**
** nextcloud.redkonflict.com**

My web server is (include version):

The operating system my web server runs on is (include version):
Ubuntu 20.04.2 LTS

My hosting provider, if applicable, is:
Hosted @ home

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 0.40.0

I have the domain redkonflict.com, which I am hosting a NextCloud instance for at home. As my ISP uses a dynamic IP, I have a tp-link provided Dynamic DNS, which nextcloud.redkonflict.com is a CNAME for. So far I haven't been able to generate certificates for this domain as it appears to be wanting an A record. Is it possible with CNAME only?

There's no problem using a CNAME, but the DNS server for tplinkdns.com (that you're making a CNAME to) needs to work. It doesn't look like it accepts TCP requests.


tplinkdns.com zone: The server(s) were not responsive to queries over TCP. (,

1 Like

In that case, I wonder if no-ip will work better.

EDIT: That worked instantly. Many thanks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.