Validate via CNAME in Domain


#1

Hello,

i have different subdomains

a.domain.de
b.domain.de

They are point to a CNAME cname.domain.de
CNAME is a DynDNS Host

I run:
sudo certbot --apache -d a.domain.de -d b.domain.de

The SSL creation fails with:

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

How can I get SSL certifate with CNAME Records?


#2

Hi @TechnikOnkel

this is a incomplete error message. Please answer all of these questions. And share the content of /var/log/letsencrypt/letsencrypt.log.


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.