Certificate Synology


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.theohuits.nl

I ran this command: No Command

It produced this output: Just 1 service certified

My web server is (include version): Synology Webserver 2.1.5-0143

The operating system my web server runs on is (include version): DSM 6.2.1-23824

My hosting provider, if applicable, is: Locally hosted on DS411j

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

I used embedded software to obtain certificait, succeeded, but the only service supported is FTPS while a whole bunch more is running, like webserver (running www.theohuits.nl), VPN, filestation, cloudstation…etc…???

I’m pretty sure I’m overlooking something crucial, hope you guys can help me out, thanks in advance!!

Dirkie


#2

Hi @dirkie

checking https://www.theohuits.nl:5001/ - there is a Letsencrypt certificate expired 24. September 2018.

How did you create this certificate. Do that again.

The integrated solution of DSM 6.2 is the best solution.


#3

Dear Juergen,

Thanks for your reply!

I initially created the certificate with the integrated software on the Synology NAS.

I tried this again hoping to reveive a new certificate, got one, but supported only 1 service… and that is my question; how to get the certificate to support the remaining services…??

Kind Regards, Dirk Zwetsloot


#4

You have a lot of active certificates.

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:www.theohuits.nl&lu=cert_search

So this part works.

Checking this

https://www.synology.com/en-us/knowledgebase/DSM/help/DSM/AdminCenter/connection_certificate

this

Get certificates from Let’s Encrypt.

works.

So you should check

Manage certificates on your Synology NAS.

so you can use one of your active certificates.