Certificate Renewal

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: tsibog.app

I ran this command:

1.) sudo service httpd stop

2.) ./certbot-auto certonly --force-renewal -w /home/tsibog/public_html/ -d tsibog.app -d www.tsibog.app

3.) sudo service httpd start

It produced this output:
-bash: ./certbot-auto: No such file or directory

Please Help, those steps i have done before is working but it isn't

Thank you so much in advanced

1 Like

Hi @Jaba8 and welcome to the LE community forum :slight_smile:

Let's try to find your installed certbot, with:
find / -name certbot*

Also, the command you've shown is missing "--webroot"
Also (also), using "force" won't make broken things "work".


Don't use this option without a very good reason. I don't see any reason to use it. So please don't.


Certainly you need to find where your certbot is installed, which is your immediate problem. After that, you can try to figure out why a simple certbot renew doesn't work--it should. Next, if you're stopping Apache, what's going to serve the challenge token when Let's Encrypt asks for it?


Hi sir thank you so much for a warm welcome :). I love to learn and share to this community . I'm a beginner using this commands , so pls be patient to me :).

iI tried to run command "sudo find / -name certbot" and this is the output

[jason_tsibogapp@centos-live ~]$ sudo find / -name certbot

and run "--webroot" and "sudo --webroot" this is output

[jason_tsibogapp@centos-live ~]$ --webroot
-bash: --webroot: command not found

[jason_tsibogapp@centos-live ~]$ sudo --webroot
sudo: unrecognized option '--webroot'
usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user] [command]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user]
[VAR=value] [-i|-s] []
usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user] file

I tried also to run "sudo which certbot"

which: no certbot in (/sbin:/bin:/usr/sbin:/usr/bin)

Please help i dont know what to do next my website is down until now thank you in advance sir @rg305 !
Im using google cloud by the way thank you


ok will not do that again thank you


It looks like you've used the certbot-auto (or even the older letsencrypt-auto) wrapper script to install and maintain your certbot instance. However, the certbot-auto wrapper script has been deprecated in favor of other installation methods.

From your output, it seems your Google Cloud instance is running CentOS, correct? Probably CentOS 7, looking at your Apache version (2.4.6), correct? Is that a virtual machine to which you have root access? If so, you might want to follow the official installation guide for CentOS 7: Certbot Instructions | Certbot


Hi sir @Osiris yes instance is runing centos, my command working before but now it isn't ok ill try to follow the installation you gave thank you so much

1 Like

You missed the "*" at the end:

That was not what was meant.

This is the command you showed:

Which is missing --webroot, and should have been:

./certbot-auto certonly --webroot -w /home/tsibog/public_html/ -d tsibog.app -d www.tsibog.app

[I removed the `--force-renewal` as that serves no purpose there]


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.