Certificate Renewal Problem

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: leadvoyage.top

I ran this command: ```
sudo letsencrypt renew


It produced this output: Unauthorized. Invalid response from www.leadvoyage.top/.well-known/acme-challenge/USfoh...

My web server is (include version): Apache 2





























The operating system my web server runs on is (include version): Unbuntu 18.4

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of `certbot --version` or `certbot-auto --version` if you're using Certbot): 0.26.1

Hi @leadvoyage

checking your configuration most looks ok ( https://check-your-website.server-daten.de/?q=leadvoyage.top ):

Domainname Http-Status redirect Sec. G
ā€¢ http://leadvoyage.top/
178.62.72.16 301 https://leadvoyage.top/ 0.063 A
ā€¢ http://www.leadvoyage.top/
178.62.72.16 301 https://www.leadvoyage.top/ 0.046 A
ā€¢ https://leadvoyage.top/
178.62.72.16 200 0.550 B
ā€¢ https://www.leadvoyage.top/
178.62.72.16 200 0.344 B
ā€¢ http://leadvoyage.top/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
178.62.72.16 301 https://leadvoyage.top/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 0.056 A
Visible Content: Moved Permanently The document has moved here . Apache/2.4.29 (Ubuntu) Server at leadvoyage.top Port 80
ā€¢ http://www.leadvoyage.top/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
178.62.72.16 301 https://www.leadvoyage.top/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 0.050 A
Visible Content: Moved Permanently The document has moved here . Apache/2.4.29 (Ubuntu) Server at www.leadvoyage.top Port 80
ā€¢ https://leadvoyage.top/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 404 0.253 A
Not Found
Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. Apache/2.4.29 (Ubuntu) Server at leadvoyage.top Port 443
ā€¢ https://www.leadvoyage.top/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 404 0.246 A
Not Found

You have a redirect http -> https, checking a file in /.well-known/acme-challenge sends the expected http status 404 - Not Found.

So find the DocumentRoot of your https vHost and use that information:

certbot run -a webroot -i apache -w yourDocumentRoot -d leadvoyage.top -d www.leadvoyage.top
1 Like

Thank you so much! It worked like a charm. Renewed my certs and tested on https://www.ssllabs.com/ssltest/analyze.html?d=

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.