Certificate renew not getting done

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: app5.juvlon.com

I ran this command:./certbot-auto

It produced this output:

My web server is (include version):Apache/2.2.15

The operating system my web server runs on is (include version):CentOS release 6.9

My hosting provider, if applicable, is:aws

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Greetings :slightly_smiling_face:

Having read your initial post, I don’t know the issue you’re facing. I visited app5.juvlon.com and was redirected to app6.juvlon.com. It looks like you have a valid Let’s Encrypt certificate that was issued on August 12 for app6.juvlon.com that is not yet ready for renewal. You could force a renewal, but you normally don’t want to do that unless you’re changing something (e.g. adding/removing a domain/subdomain, wanting a new private key). Since you’re redirecting app5.juvlon.com to app6.juvlon.com, the Let’s Encrypt certificates you generated on August 29 and August 30 for app5.juvlon.com obviously aren’t going to do anything.

You can see the full history of certificates for juvlon.com at https://crt.sh/?q=juvlon.com.

How can we help?

hello thanks for your reply
but actually app5.juvlon.com is different server i had renew but not showing in https://www.sslshopper.com/ssl-checker.html#hostname=app5.juvlon.com its not showing renew

1 Like

At https://crt.sh/?q=app5.juvlon.com I can clearly see two new certificates issued on August 29 and August 30 for app5.juvlon.com. From the link you posted, I think the following may be misleading you:

These results were cached from August 2, 2020, 10:26 pm PST to conserve server resources.

Hello Sir

i had renewed, but its not showing renewed.

1 Like

The link you posted has had really-outdated, cached results from August 2. I did you a favor and updated your results. Check your link again. :slightly_smiling_face:

https://www.sslshopper.com/ssl-checker.html#hostname=app5.juvlon.com

Thank you sir, for your kind support, its renewed.

1 Like

You’re very welcome. :slightly_smiling_face:

I’m still not sure how a certificate for a redirected website will be useful, but at least it’s updating correctly.

somewhere its use internally for program purpose.

1 Like

Ah. OK. Sometimes people generate certificates for staging servers, so I could see that.