Certificate issues - works in chrome but not IE


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://www.appreciateatnationalgrid.com/

I ran this command: N/A

It produced this output: certificate error in IE stating issued for a different website address

My web server is (include version): n/a

The operating system my web server runs on is (include version): n/a

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don’t know): n/a

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): n/a


#2

Hi @james.mountford

your https://www.appreciateatnationalgrid.com/ doesn’t work. You have a certificate with only one name:

DNS-Name: appreciateatnationalgrid.com

So create a new certificate with two names:

appreciateatnationalgrid.com www.appreciateatnationalgrid.com

With Certbot, it’s something like

certbot -d appreciateatnationalgrid.com -d www.appreciateatnationalgrid.com ...[other parameter]


#3

hello @JuergenAuer

thank you for your response and advice. I was under the impression letsencrypt created and applied the certificates for this URL, is that correct?

many thanks
james


#4

Letsencrypt does that what you want. If you order only a certificate with one name appreciateatnationalgrid.com - you get that.

How did you create that certificate?

I ran this command:


#5

thank you, we have now resolved the issue with your advice


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.