Certificate issued, only showing on localhost

Some information before my issue:

  • Laravel project
  • Nginx 1.14.2
  • Debian 9
  • Certbot version 0.2.8
  • Hosting on a Raspberry Pi on my home network
  • Using a domain through freedns.afraid.org

I am very new to much of this, so I am sorry if I am failing to understand something.

So I roughly followed this guide, except I also tried the command

sudo letsencrypt certonly --webroot /var/www/projectname/public -d domain.com -d www.domain.com

My website is running, but https does not work correctly. From outside the network, it gives me the error:


Subject: Daniel

Issuer: Daniel

Expires on: Sep 6, 2006

Which is, from what I can tell, potentially a certificate being issued by my modem. It doesn’t work on localhost, but it lists who it’s issued to (my domain), who it’s issued by (LetsEncrypt), the validity, and so on, and all seems to be correct. The command “letsencrypt certificates” list the cert name, domains, date, and so on. Also, I tried the config shown here.

I can give the domain if needed, but it only currently shows what I posted. I would hugely appreciate any help whatsoever.

Hi @elanks,

Maybe your router forwards port 80 to your web server but answers port 443 itself, rather than forwarding it to the server? In this case you would be able to obtain certificates and deploy them on the server, but outside visitors would have no way of accessing the server via HTTPS—only via HTTP.

1 Like

I don’t suppose the solution would be as simple as forwarding a different port and changing it in the config? I tried but it didn’t do anything.

Well it appears I inexplicably did not have 443 forwarded… I was so certain that I did. Whew. The certificate works now, but the website just 404s for some reason. But that’s beyond this topic.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.