Certificat, sous domaine et redirection

Veuillez remplir les champs ci-dessous pour que nous puissions vous aider. Remarque : vous devez fournir votre nom de domaine pour obtenir de l’aide. Les noms de domaine des certificats émis sont tous rendus publics dans les journaux de Transparence de Certificat (par exemple, crt.sh | example.com). Par conséquent, le fait de ne pas indiquer votre nom de domaine ici n’aide pas à le garder secret, mais rend plus difficile pour nous le fait de vous aider.

Je peux lire des réponses en Anglais : non ou alors non technique

Mon nom de domaine est : imagein-sante.fr

J’ai exécuté cette commande :

Elle a produit cette sortie :

Mon serveur Web est (inclure la version) : Apache/2.4.38

Le système d’exploitation sur lequel mon serveur Web s’exécute est (version incluse) : Debian GNU/Linux 10

Mon hébergeur, le cas échéant, est : OVH

Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) : Oui

J’utilise un panneau de configuration pour gérer mon site (non, ou fournit le nom et la version du panneau de configuration) : non

Bonjour, j'ai sur le poste de mon patron le logiciel Kaspersky qui émet une alerte de certification sur le domaine "imagein-sante.fr", en disant que cette adresse n'est pas sur, car le certificat de https://imagein-sante.fr est web.imagein-sante.fr

J'ai le site web qui est accessible sur l'url www.imagein-sante.fr, avec des alias en imagein-sante.fr, www.imagein-sante.com et imagein-sante.com (avec une redirection dans le vhost des alias vers https://www.imagein-sante.fr).

L'adresse web.imagein-sante.fr est défini comme reverse dns dans ovh.
Et je n'ai pas de trace d'une configuration de site en "web.imagein-sante.fr" sur apache.
Si je tape l'url "web.imagein-sante.fr" j'ai une page blanche (mais je sais pas pourquoi)

Si je tape l'url "imagein-sante.fr" j'ai bien une redirection directement vers "https://www.imagein-sante.fr"
Si je tape "https://imagein-sante.fr", le navigateur m'affiche une erreur de certificat :

Les sites web justifient leur identité par des certificats. Firefox ne fait pas confiance à ce site, car il utilise un certificat qui n’est pas valide pour imagein-sante.fr. Le certificat n’est valide que pour web.imagein-sante.fr.
 
Code d’erreur : SSL_ERROR_BAD_CERT_DOMAIN

Dans OVH, dans la zone dns de imagein-sante.fr j'ai ceci concernant "web" :

web.imagein-sante.fr CNAME imagein-sante.fr.

La personne qui a mis en place le site et la configuration n'est plus la. Du coup je sais pas

Merci de vos retours et de votre aide :wink:

Hi @l.plot, please excuse my English - and welcome to the LE community forum :slight_smile:

LE prefers IPv6 when present.
I can connect to your domain via IPv4 but NOT via IPv6:

curl -Iki4 http://imagein-sante.fr/
HTTP/1.1 301 Moved Permanently
Date: Fri, 09 Jul 2021 18:33:56 GMT
Server: Apache/2.4.38 (Debian)
Location: https://www.imagein-sante.fr/
Content-Type: text/html; charset=iso-8859-1

curl -Iki6 http://imagein-sante.fr/
curl: (56) Recv failure: Connection reset by peer

curl -Iki4 https://www.imagein-sante.fr/
HTTP/1.1 200 OK
Date: Fri, 09 Jul 2021 18:35:28 GMT
Server: Apache/2.4.38 (Debian)
Link: <https://www.imagein-sante.fr/wp-json/>; rel="https://api.w.org/"
Link: <https://www.imagein-sante.fr/>; rel=shortlink
Content-Type: text/html; charset=UTF-8

curl -Iki6 https://www.imagein-sante.fr/
curl: (7) Failed to connect to www.imagein-sante.fr port 443: Connection timed out
1 Like

Hi @rg305, thank you for your response.

Dans la configuration dns d'ovh du nom de domaine imagein-sante.fr j'ai bien une entrée AAAA vers l'adresse IPv6 du serveur.

Est ce qu'il doit y avoir un configuration d'apache pour la prise en compte de l'IPv6 sur le serveur ?

1 Like

Hi @l.plot
Yes, please show the output of:
sudo apachectl -S

La commande me retourne ceci :

VirtualHost configuration:
*:80                   is a NameVirtualHost
         default server web.imagein-sante.fr (/etc/apache2/sites-enabled/000-web.imagein-sante.fr.conf:2)
         port 80 namevhost web.imagein-sante.fr (/etc/apache2/sites-enabled/000-web.imagein-sante.fr.conf:2)
         port 80 namevhost rh.imagein-sante.fr (/etc/apache2/sites-enabled/rh.imagein-sante.fr.conf:1)
                 alias harmony-rh.imagein-sante.fr
                 alias harmony-rh.imagein-sante.com
                 alias rh.imagein-sante.com
         port 80 namevhost wordpress.imagein-sante.fr (/etc/apache2/sites-enabled/wordpress.imagein-sante.fr.conf:1)
         port 80 namevhost www.imagein-sante.fr (/etc/apache2/sites-enabled/www.imagein-sante.fr.conf:2)
                 alias imagein-sante.fr
                 alias imagein-sante.com
                 alias www.imagein-sante.com
         
*:443                  is a NameVirtualHost
         default server web.imagein-sante.fr (/etc/apache2/sites-enabled/000-web.imagein-sante.fr.conf:19)
         port 443 namevhost web.imagein-sante.fr (/etc/apache2/sites-enabled/000-web.imagein-sante.fr.conf:19)
         port 443 namevhost rh.imagein-sante.fr (/etc/apache2/sites-enabled/rh.imagein-sante.fr.conf:10)
         port 443 namevhost rh.imagein-sante.fr (/etc/apache2/sites-enabled/rh.imagein-sante.fr.conf:31)
                 alias harmony-rh.imagein-sante.fr
                 alias harmony-rh.imagein-sante.com
                 alias rh.imagein-sante.com
         port 443 namevhost www.imagein-sante.fr (/etc/apache2/sites-enabled/www.imagein-sante.fr.conf:20)
         port 443 namevhost imagein-sante.fr (/etc/apache2/sites-enabled/www.imagein-sante.fr.conf:41)
                 alias imagein-sante.com
                 alias www.imagein-sante.com
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33
Group: name="www-data" id=33

J'ai supprimé les info qui n’étaient pas lié au domaine imagein-sante.fr

Please show these two files:
/etc/apache2/sites-enabled/rh.imagein-sante.fr.conf
/etc/apache2/sites-enabled/www.imagein-sante.fr.conf

rh.imagein-sante.fr.conf :

<VirtualHost *:80>
    ServerAdmin webmaster@harmony-rh.fr
    ServerName  rh.imagein-sante.fr
    ServerAlias harmony-rh.imagein-sante.fr harmony-rh.imagein-sante.com rh.imagein-sante.com

    RewriteEngine On
    RewriteRule ^ https://rh.imagein-sante.fr%{REQUEST_URI} [L,QSA,R=permanent]
</VirtualHost>

<VirtualHost *:443>
    ServerAdmin webmaster@harmony-rh.fr
    ServerName  rh.imagein-sante.fr

    ErrorLog /var/log/apache2/rh.imagein-sante.fr-error.log
    TransferLog /var/log/apache2/rh.imagein-sante.fr-access.log

    SSLCertificateFile /etc/letsencrypt/live/harmony-rh.fr/cert.pem
    SSLCertificateChainFile /etc/letsencrypt/live/harmony-rh.fr/chain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/harmony-rh.fr/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf

    DocumentRoot /var/www/imagein-sante.fr/www/public
    <Directory /var/www/imagein-sante.fr/www/public/>
        AllowOverride All
        Options -Indexes +FollowSymLinks
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

<VirtualHost *:443>
    ServerAdmin webmaster@harmony-rh.fr
    ServerName  rh.imagein-sante.fr
    ServerAlias harmony-rh.imagein-sante.fr harmony-rh.imagein-sante.com rh.imagein-sante.com

    RewriteEngine On
    RewriteRule ^ https://rh.imagein-sante.fr%{REQUEST_URI} [L,QSA,R=permanent]
</VirtualHost>

Je vois que les fichiers LE correspondent au nom de domaine "harmony-rh.fr" alors que c'est pour le site rh.imagein-sante.fr.
Je regarde pour faire la modification dans l’après-midi.

www.imagein-sante.fr.conf :

<VirtualHost *:80>
    ServerAdmin webmaster@imagein-sante.fr
    ServerName  www.imagein-sante.fr
    ServerAlias imagein-sante.fr imagein-sante.com www.imagein-sante.com

    RewriteEngine On
    RewriteCond %{REQUEST_URI} !^/\.well-known/
    RewriteRule ^ https://www.imagein-sante.fr%{REQUEST_URI} [L,QSA,R=permanent]

    DocumentRoot /var/www/imagein-sante.fr/www/public
    <Directory /var/www/imagein-sante.fr/www/public/>
        AllowOverride All
        Options -Indexes +FollowSymLinks
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

<VirtualHost *:443>
    ServerAdmin webmaster@imagein-sante.fr
    ServerName  www.imagein-sante.fr

    ErrorLog /var/log/apache2/www.imagein-sante.fr-error.log
    TransferLog /var/log/apache2/www.imagein-sante.fr-access.log

    SSLCertificateFile /etc/letsencrypt/live/www.imagein-sante.fr/cert.pem
    SSLCertificateChainFile /etc/letsencrypt/live/www.imagein-sante.fr/chain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/www.imagein-sante.fr/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf

    DocumentRoot /var/www/imagein-sante.fr/www/public
    <Directory /var/www/imagein-sante.fr/www/public/>
        AllowOverride All
        Options -Indexes +FollowSymLinks
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

<VirtualHost *:443>
    ServerAdmin webmaster@imagein-sante.fr
    ServerName  imagein-sante.fr
    ServerAlias imagein-sante.com www.imagein-sante.com

    RewriteEngine On
    RewriteRule ^ https://www.imagein-sante.fr%{REQUEST_URI} [L,QSA,R=permanent]
</VirtualHost>

That is good.
Let us know if that fixes things.