Certbot service failed to load after ubuntu distupgrade to 20.04

My domain is: https://stajl.nl

I ran this command: systemctl --state=failed

It produced this output:

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): ISPConfig

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot: 0.40

I have installed the ubuntu package new with:
apt-get --reinstall install certbot

Can anyone give hint on how to reinstall certbot?
I have found a lockfile, could it be the cause?

Regards,
Jan

1 Like

Hi @janvl Welcome to the community!
I was just reading @_az's post about

An was reminded that there is "A New Way to Install Certbot on Linux"
Might be a couple useful posts to check out.

4 Likes

Thank you Rip,

i would however like to stay as close as possible to the basic-install of the server because i run ISPConfig as Serverpanel and in case of problems it is easier if i run a similar install as is written in the tutorial on how to build the server.

I hope someone has a hint on how to "repair" a certbot/letsencrypt-install where there are already over 20 domains with certificates.

Regards,
Jan

2 Likes

If the defaults were used on install, there is almost no wrong way to uninstall and reinstall certbot.
[unless you go rouge and do anything manually within /etc/letsencrypt/]

2 Likes

There is!
I first did a "apt remove certbot" - that did not function could still not start the service.
Then "apt remove certbot" and after that "apt install certbot".

That has broken my apacheserver because ALL certificates were gone.
With "certbot certonly" i have generated new certificates but they make trouble with apache because in the /etc/apache2/sites-available apache links to the old certificates that are no longer there.

I know i did it myself but i am not happy with it, it will cost loads of time getting this working again.

1 Like

You must have done more than just:

Neither will delete any certificate files.

3 Likes

I did.
remove and install did not result in a functioning certbot service.

I did a purge - that is my mistake i know. I will have to move all sites to another server and install this one new.

Doing a distupgrade when you run apache, mariadb, php, postfix and certbot still is no good idea.
This was my second distupgrade in over 20 years with linux, still no good idea, better build a new system and copy the data.

When another one should want to re-install certbot, then a warning not to purge might be a good idea.

I still like certbot very much, ran it manually when it just started on my local machine and copied the files to the server, specifically on this server it ran very smoothly.

Thanks anyway, as i said i made the mistake myself.

Regards,
Jan

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.