Certbot accidentally uninstalled by apt-get (?) on Ubuntu 18.04.2 LTS

certbot appears to have been uninstalled. My (mail) server is working fine, but the renewal cronjob which used to work now couldn’t even find certbot.

I installed it in May or June using the commands listed here https://certbot.eff.org/lets-encrypt/ubuntubionic-apache, which finishes with (note: I didn’t skip to that point of the instructions)

The ONLY commands I run on the system (<1x/week) are

 sudo apt-get update; sudo apt-get dist-upgrade; sudo apt-get autoremove; sudo shutdown -r 

Between executions of the cron job (i.e. June 5 and July 5) certbot was apparently removed or destroyed by the apt-get process.

I just reinstalled via the instructions and certbot renew executes, but I’m trying to figure out what happened to figure out if this was a one-time thing or what went wrong so that my certificates don’t expire on me if I don’t pay attention.

Thanks in advance.

My domain is: mail.forbesiplaw.com

I ran this command: certbot renew (via cronjob that worked in June, though the cert wasn’t due for renewal)

relevant crontab -l

00 06 5 * * certbot renew

It produced this output:

My web server is (include version):
Apache

The operating system my web server runs on is (include version):
Ubuntu 18.04.2 LTS

My hosting provider, if applicable, is:
AWS

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
0.31 now. I installed using apt-get in May or June of this year, and the version number in my renewal configuration file before I reinstalled certbot was also 0.31.0.

Is there any chance that you upgraded from an older codename release of Ubuntu?

apt dist-upgrade + apt autoremove can definitely cause Certbot to get removed, especially if you upgraded to a new Ubuntu codename. Those commands should be used with care.

No, I’ve stayed on 18.04 LTS. I am not sure if I’ve always been on 18.04.2 LTS, but it started as a clean 18.04 install (although the mail data files came from another server, that is just one partition and should have nothing to do with anything).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.