Certbot plugins command doesnt show dnsmadeeasy plugin but says its installed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
certbot certonly -d *.bluegrasscleaning.com -dns-dnsmadeeasy

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?

1: Spin up a temporary webserver (standalone)
2: Place files in webroot directory (webroot)

Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 2
Plugins selected: Authenticator webroot, Installer None

You have an existing certificate that contains a portion of the domains you
requested (ref: /etc/letsencrypt/renewal/bluegrasscleaning.com.conf)

It contains these names: *.bluegrasscleaning.com

You requested these names for the new certificate: *.bluegrasscleaning.com,

Do you want to expand and replace this existing certificate with the new

(E)xpand/(C)ancel: e
Renewing an existing certificate
An unexpected error occurred:
The server will not issue certificates for the identifier :: Error creating new order :: Cannot issue for "ns-dnsmadeeasy": Domain name needs at least one dot
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): OpenLiteSpeed 1.7.14

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is: VULTR

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

Hi @kivers21 and welcome to the LE community forum :slight_smile:

It looks like this command:

Is being interpreted as:
certbot certonly -d *.bluegrasscleaning.com -d ns-dnsmadeeasy

As seen here:

Try it this way:
certbot certonly -d *.bluegrasscleaning.com --dns-dnsmadeeasy
[with two dashes before dns]

1 Like

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Could not choose appropriate plugin: The requested dns-dnsmadeeasy plugin does not appear to be installed
The requested dns-dnsmadeeasy plugin does not appear to be installed

I am trying to remember the command line to install the plugin but even when i run that it says the plugin is installed.

root@wireband:~# sudo snap install certbot-dns-dnsmadeeasy
snap "certbot-dns-dnsmadeeasy" is already installed, see 'snap help refresh'
root@wireband:~# snap refresh
All snaps up to date.

You have certbot v0.40.0 and the DNS plugin was installed via snap?

Yes, is that a noob mistake?

If you have snap, then uninstall certbot and then install the snap version of certbot.
[the two snaps might be more compatible]
For complete instructions, see: Certbot (eff.org)

1 Like

Still says its an unrecognized command.

woo hoo! thanks you!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.