Certbot on Raspbian Jessie (certbot installed doesn't do anything and no output is received


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: pi.ffuent.es

I ran this command:

I followed the instructions from https://certbot.eff.org/lets-encrypt/debianjessie-nginx I added some settings so that .well-known content was allowed. I run: “sudo certbot certonly -a webroot --webroot-path=/var/www/html -d pi.ffuent.es” but after a few seconds it only stops with no warning message and it doesn’t do anything.

It produced this output: No output (I have no output on screen neither do I have any logs to seek an error within /etc/letsencrypt).

My web server is (include version): nginx 1.6.2

The operating system my web server runs on is (include version): Raspbian Jessie

My hosting provider, if applicable, is: none

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

Hi,

Is there any output at all?

Can you please also try to run sudo certbot certonly and share us any output?

(Did you try reinstalling certbot?)

Thank you


#3

I reinstalled certbot ( sudo apt-get install --reinstall certbot) but I ran sudo certbot certonly and I don’t get any output. I only get an output when I write something wrong and it displays “illegal instruction”.


#4

Please see


#5

I think I’m gonna upgrade to Stretch and see what happens.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.