Certbot on Raspberry Pi - No Dialogs

Hey guys,

i just intalled certbot on my rpi with raspian.
When i try to get a cert certbot doenst do anything…

I already tried to just get the latest version from GitHub -> Same behavior
Getting it from testing repo -> Same behavior
Getting it from backports repo -> Same behavior

Somebody knows another way to get it running?

Thank you

There is currently a service disruption, see here: http://letsencrypt.status.io/

@Mike1082 dont think that my problem is issued by this service disruption.
In this case certbot should say couldnt connect or nah? Already had this problem on a different device some time ago…

Try checking your log files. Not sure if the location will be the same on the Pi (I am running in Docker) but for me it was /var/log/letsencrypt. I ran:

# tail -f /var/log/letsencrypt/letsencrypt.log

The output showed I was getting a ClientError: <Response 504> when trying to contact acme-v01.api.letsencrypt.org (which is related to the current outage).

Tried again. Which plugin is meant in the following…
2017-05-20 14:21:21,401:DEBUG:certbot.main:Root logging level set at 20 2017-05-20 14:21:21,432:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log 2017-05-20 14:21:21,461:DEBUG:certbot.main:certbot version: 0.10.2 2017-05-20 14:21:21,464:DEBUG:certbot.main:Arguments: ['--apache', '-d', 'domain.de', '-d', 'sub.domain.de', '-d', 'sub.domain.de', '-d', 'sub.domain.de'] 2017-05-20 14:21:21,490:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#webroot,PluginEntryPoint#null,PluginEntryPoint#manual,PluginEntryPoint#standalone) 2017-05-20 14:21:21,502:DEBUG:certbot.plugins.selection:Requested authenticator apache and installer apache 2017-05-20 14:21:21,506:DEBUG:certbot.plugins.selection:No candidate plugin 2017-05-20 14:21:21,509:DEBUG:certbot.plugins.selection:No candidate plugin 2017-05-20 14:21:21,512:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None 2017-05-20 14:21:21,515:INFO:certbot.main:Could not choose appropriate plugin: The requested apache plugin does not appear to be installed 2017-05-20 14:21:21,559:DEBUG:certbot.main:Exiting abnormally: Traceback (most recent call last): File "/usr/bin/certbot", line 11, in <module> load_entry_point('certbot==0.10.2', 'console_scripts', 'certbot')() File "/usr/lib/python2.7/dist-packages/certbot/main.py", line 849, in main return config.func(config, plugins) File "/usr/lib/python2.7/dist-packages/certbot/main.py", line 617, in obtain_cert installer, auth = plug_sel.choose_configurator_plugins(config, plugins, "certonly") File "/usr/lib/python2.7/dist-packages/certbot/plugins/selection.py", line 197, in choose_configurator_plugins diagnose_configurator_problem("authenticator", req_auth, plugins) File "/usr/lib/python2.7/dist-packages/certbot/plugins/selection.py", line 272, in diagnose_configurator_problem raise errors.PluginSelectionError(msg) PluginSelectionError: The requested apache plugin does not appear to be installed

hi @FlorianTaut

Have you tried searching the forums?

Few people have come across the issue you are having.

Also it’s useful to articulate how you installed certbot as I believe there is an issue with some of the installers.


Hi @FlorianTaut

Also if you read the log carefully it tells you exactly what the problem is

Certbot has a concept of plugins and one of these plugins is called the Apache plugin.

If you run certbot plugins you will see a list of available plugins

I believe your issue is that you are trying to use the apache plugin without installing it.

2017-05-20 14:21:21,515:INFO:certbot.main:Could not choose appropriate plugin: The requested apache plugin does not appear to be installed


Yes but want to know how the name of the plugin is. I know that something with Apache doesn’t work but the logs don’t help my finding out the name of the required plugin.

Hi @FlorianTaut,

The packages that you need are augeas-lenses and libaugeas0 but they should be installed automatically if you are using the last certbot version (0.14.1)… at least on Raspberry Pi 3 and raspbian-Jessie that is what I’m using ( it could work fine in Raspberry Pi 2 but I don’t have one to test it)

So, first remove the virtualenv and install certbot-auto as root.

cd /root/
rm -rf .local/share/letsencrypt/
wget https://dl.eff.org/certbot-auto
chmod a+x certbot-auto
./certbot-auto --apache

certbot-auto will try to install all the needed packages (it could take several minutes).

Just in case you want to compare, these are my sources:

root@miniwinipoint:~# grep -i '^[a-z]' /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi

root@miniwinipoint:~# grep -i '^[a-z]' /etc/apt/sources.list.d/raspi.list
deb http://archive.raspberrypi.org/debian/ jessie main ui

Edit: These are the versions of main packages that certbot-auto will try to install.

# dpkg -l  | grep -E '(augeas-lenses |ca-certificates |gcc |libaugeas0 |libffi-dev |libssl-dev |openssl |ii  python |python-dev |python-virtualenv |virtualenv )'
ii  augeas-lenses                  1.2.0-0.2+deb8u1                 all          Set of lenses needed by libaugeas0 to parse config files
ii  ca-certificates                20141019+deb8u3                  all          Common CA certificates
ii  gcc                            4:4.9.2-2                        armhf        GNU C compiler
ii  libaugeas0                     1.2.0-0.2+deb8u1                 armhf        Augeas configuration editing library and API
ii  openssl                        1.0.1t-1+deb8u6                  armhf        Secure Sockets Layer toolkit - cryptographic utility
ii  python                         2.7.9-1                          armhf        interactive high-level object-oriented language (default version)
ii  python-dev                     2.7.9-1                          armhf        header files and a static library for Python (default)
ii  python-virtualenv              1.11.6+ds-1                      all          Python virtual environment creator
ii  python3-virtualenv             1.11.6+ds-1                      all          Python virtual environment creator
ii  virtualenv                     1.11.6+ds-1                      all          Python virtual environment creator


1 Like

Thanks @sahsanu,

I’ll try it today.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.