Certbot issue - DNS problem: NXDOMAIN looking up A for teleconference.co

Hi guys, I’m new to setting up ubuntu server, and I wanted to enabled my apache web server to be accessed using “https”… I had followed the steps provided by certbot.org… and i still face some issue when setting up… The version of Ubuntu server that i’m currently using is 16.04.
After i entered the command “sudo certbot --apache”, I’ve been prompted with the error stated below…

Failed authorization procedure. teleconference.co (tls-sni-01): urn:acme:error:connection :: 
The server could not connect to the client to verify the domain :: DNS problem: NXDOMAIN 
looking up A for teleconference.co

IMPORTANT NOTES:
- The following errors were reported by the server:
Domain: teleconference.co
Type:     connection
Detail:    DNS problem: NXDOMAIN looking up A for teleconference.my

To fix these errors, please make sure that your domain name was 
entered correctly and the DNS A/AAAA record(s) for that domain 
contain(s) the right IP address. Additionally, please check that your 
computer has a publicly routable IP address and that no firewalls are 
preventing the server from communication with the client. If you're using 
the webroot plugin, you should also verify that you are serving files from 
the webroot path you provided.

I had found several similar issues from this forum, i had tried to enable my https port 443 in firewall using the command “sudo ufw allow 443”… and still having the same issue…
Need some helps from experts for this issues… Thanks in advanced

hi @yanzai3292

Did you have a look at what the error message is actually saying

can you also try sticking to the format of the qusetions as it makes it easier to find the information rather than having to go through the various bits and pieces

Port 443 is still not open (not from where I am anyway)

image

Andrei

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.