Certbot installed SSL correctly but I am unable to use SSL

I successfully ran the certbot using the instructions found here: https://certbot.eff.org/#ubuntutrusty-apache
I selected redirect so that all traffic would automatically be https. I tried going to the website but it doesn’t work. When I try manually typing https://uss-artemis.com it works, but not for my wiki.

If anyone has any thoughts on this, I am more than open to hearing them. Thank you so much in advance!

My domain is: uss-artemis.com

I ran this command:
certbot --apache

It produced this output:
Congratulations! You have successfully enabled https://uss-artemis.com

My web server is (include version):

The operating system my web server runs on is (include version):
Ubuntu server 14.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Webmin 1.860

Please elaborate on the failing "wiki" part.
For now, as best as I can see:
The WIKI link (https://uss-artemis.com/wiki/index.php) fails, as it reverts to http via redirection.
But the resulting http link (http://uss-artemis.com/wiki/index.php/Main_Page) also works fine via https:

So the problem is somewhere within the explicit "redirection":
wget https://uss-artemis.com/wiki/index.php
--2017-10-14 00:57:46-- https://uss-artemis.com/wiki/index.php
Resolving uss-artemis.com (uss-artemis.com)...
Connecting to uss-artemis.com (uss-artemis.com)||:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://uss-artemis.com/wiki/index.php/Main_Page [following]
--2017-10-14 00:57:46-- http://uss-artemis.com/wiki/index.php/Main_Page
Connecting to uss-artemis.com (uss-artemis.com)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]

1 Like

Probably a setting in the Wiki software.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.