Certbot generating blank PrivKey.pem

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: dolomitisistemas.com.br

I ran this command: certbot certonly --manual -d www.dolomitisistemas.com.br

It produced this output:

  • Congratulations! Your certificate and chain have been saved at:
    Your key file has been saved at:
    Your cert will expire on 2020-01-20. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot
    again. To non-interactively renew all of your certificates, run
    “certbot renew”

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.37.1

Hello, I’m new to certbot. I’ve installed Certbot via Homebrew on my Mac and then I ran sudo certbot certonly --manual -d www.dolomitisistemas.com.br . It generated the files in the folder… the fullchain.pem is ok, but the privkey.pem is blank!

I’ve already tried to uninstall the brew plugin and install it again, but the same problem occoured.

Can someone help me? Thanks in advance.

1 Like

Please show:
ls -l /etc/letsencrypt/live/dolomitisistemas.com.br/
ls -l /etc/letsencrypt/archive/dolomitisistemas.com.br/

1 Like

total 8
-rw-r–r-- 1 root wheel 692 Oct 22 21:11 README
lrwxr-xr-x 1 root wheel 47 Oct 22 21:11 cert.pem -> …/…/archive/dolomitisistemas.com.br/cert1.pem
lrwxr-xr-x 1 root wheel 48 Oct 22 21:11 chain.pem -> …/…/archive/dolomitisistemas.com.br/chain1.pem
lrwxr-xr-x 1 root wheel 52 Oct 22 21:11 fullchain.pem -> …/…/archive/dolomitisistemas.com.br/fullchain1.pem
lrwxr-xr-x 1 root wheel 50 Oct 22 21:11 privkey.pem -> …/…/archive/dolomitisistemas.com.br/privkey1.pem


total 32
-rw-r–r-- 1 root wheel 1931 Oct 22 21:11 cert1.pem
-rw-r–r-- 1 root wheel 1647 Oct 22 21:11 chain1.pem
-rw-r–r-- 1 root wheel 3578 Oct 22 21:11 fullchain1.pem
-rw------- 1 root wheel 1708 Oct 22 21:11 privkey1.pem

1 Like

Well those files don’t look empty.
Perhaps your program can’t “see them”… and thinks that “they must be empty”.
[may be a permissions problem]

Notice how most of the files show “-rw-r–r--” while the private key file shows “-rw------”.
So you would need to be running as “root” to read that file.

1 Like

You are right!
The problem was with the permitions.
Thanks for the help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.