Certbot Installed, Test Results Fine, Yet Site Still Unsecure

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: pixelmodo.com

I ran this command: certbot

It produced this output: MPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:
    Your key file has been saved at:
    Your cert will expire on 2020-02-12. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot renew”

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

My web server is (include version): apache

The operating system my web server runs on is (include version): unbuntu 16

My hosting provider, if applicable, is: digital ocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

1 Like

Hi @seun

you use Cloudflare, so your real server is invisible.

And you have fatal redirects https -> http, Grade F - https://check-your-website.server-daten.de/?q=pixelmodo.com

So your site is insecure, http is used, not https.

First step: Remove these wrong redirects, may be Cloudflare, may be your server.

Second step: Add correct redirects http -> https.

1 Like

Hi @JuergenAuer Thanks for the response.

I just removed the site off Cloudflare right now.

And I did a reinstall of certbot and I selected the redirect option.

All good now.

Many Thanks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.