Certbot failed to authenticate some domains

Hello, I'm kodama.

I ran a command for generating a renew certificate on Certbot.
However, some domains couldn't generate for the renew certificate by the following DNS error.

== error message ==
DNS problem: SERVFAIL looking up CAA for domain name1 - the domain's nameservers may be malfunctioning.

DNS problem: SERVFAIL looking up TXT for _acme-challenge.domain name2 - the domain's nameservers may be malfunctioning.

Hint: The Certificate Authority failed to verify the DNS TXT records created by the --manual-auth-hook. Ensure that this hook is functioning correctly and that it waits a
sufficient duration of time for DNS propagation. Refer to "certbot --help manual" and the Certbot User Guide.

=============

I could generate other domains for the renew certificate completely on Certbot, but I could not generate just specific 2 domains.

I would like to give me advices for resolving this error.

Thanks a lot for your help.

1 Like

Are they real domains? Can you share the real domain names?

1 Like

Hi @kodama and welcome to the LE community forum :slight_smile:

The best advice would be for you to answer these questions:
[which should have been presented to you when you opened a help topic]


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):