Certbot does not show my domain in available list

My domain is: dinargururv.com

I ran this command: sudo certbot --apache

I have just installed a certificate for 8 domains with no issues, but for some reason this particular domain never shows up on the list as an available domain to install a certificate.

I have the conf file in my sites-available folder
I have ServerAlias and ServerName setup just like all the other
Checked permissions in the file and it was fine like the others

But no matter what I do after running sudo certbot --apache when the list of domains pops up I can see all the other domains show up except the one I am currently doing.

What was weird is that before I had even setup a certificate for that domain I checked to see what certificated I had on the server and it showed that domain in the list. What was crazy is I didn’t even set it up yet so I have no idea what happened.

What I did do different with this domain is that I copied a previos conf file that had already contain the Rewrite conditions that Certbot creates so I was not sure if after restarting apache that screwed thing up.

I went back and recreated the file instead of copied and I delted the existing cert with sudo certbot delete and I still can’t get that domain to appear.

I even tried to install it manually with sudo certbot --apache -d dinargururv.com -d www.dinargururv.com but that still didn’t work.

Any ideas?

1 Like

There needs to be a corresponding site-enabled entry.
[ see: Ubuntu Manpage: a2ensite, a2dissite - enable or disable an apache2 site / virtual host ]

What names are shown with:
apachectl -S

1 Like

I never had to create anything in the sites-enabled folder with any of my other domains. They were already auto generated. Here are the steps I did with all my previous domains that worked fine.

  1. I would create my conf file in the sites-available folder -> example.com.conf
  2. I would run the Certbot command sudo certbot --apache
  3. The domain example.com would appear on the list to choose from
  4. I choose the domains by the corresponding numbers
  5. It would auto-generate the certificate and all was good.

I did this multiple times with no problem, but for this particular domain it never shows up on the list for me to choose.

Hi @cbielich

that's not possible, as @rg305 wrote. A symbolic link in sites-enabled is required. May be you have used a2ensite to enable your site.

Please show the output of

apachectl -S

and the output of the sites-enabled folder.

PS: Checking your domain you have already a certificate created - https://check-your-website.server-daten.de/?q=dinargururv.com

Issuer not before not after Domain names LE-Duplicate next LE
Let's Encrypt Authority X3 2019-12-19 2020-03-18 dinargururv.com, www.dinargururv.com - 2 entries duplicate nr. 1
cPanel, Inc. Certification Authority 2019-11-09 2020-02-07 dinargururv.com, mail.dinargururv.com, www.dinargururv.com - 3 entries

But why there are so much cPanel - certificates? First is from 2017-11-16 23:00:00.

And the domain uses the wrong certificate:

CN=fatguyshirts.com
	17.12.2019
	16.03.2020
expires in 87 days	fatguyshirts.com, www.fatguyshirts.com - 2 entries

Looks like you have a standard port 443 vHost that answers.

So it's only an certificate installation, not a certificate creation problem.

What says

certbot certificates
1 Like

OMG how in the world did I go so long and not realize I didn’t run sudo a2ensite first…

I’m an idiot, never mind and thanks!

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.