Certbot does not renew

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.homadorma.com

I ran this command: certbot certbonly --nginx

It produced this output: connection refused

My web server is (include version):

The operating system my web server runs on is (include version): ubuntu-xenial-16.04-amd64-server-20180306

My hosting provider, if applicable, is: ec2 aws

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.31.0

1 Like

Welcome Back to the Let's Encrypt Community, Cypher :slightly_smiling_face:

According to crt.sh, it looks like you successfully acquired a certificate for www.homadorma.com today.

1 Like

that's right! Thanks!

We ran the same command a few times. Eventually it worked. Not sure what happened though.

2 Likes

Glad it worked. :blush:

If it's inconsistent, I've found that this can be an indication of either a firewall of some kind or a goofy DNS server interfering.

1 Like

Some additional info to add. On the day when we were not able to renew the ssl, the site that failed was homadorma.com. However, our other site, zhuwojia.net, the ssl renewal was working without any issue. Here are the difference in these 2 sites.

zhuwojia.net: domain registered on namesilo. DNS controlled by namesilo. Site hosted on AWS.
homadorma.com: domain registered on namesilo. DNS controlled in Amazon Route 53. Site hosted on AWS.

Later on the same day, both renewal worked well.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.