Certbot can't decode utf-8 char 0xff

Unable to launch Certbot - I have tried apt purge & reinstall. I've also updated everything to the latest versions. I have not had issues in the past, but recently received an email to alert me to expiring certs which made me check. Now unable to launch certbot in any form. Many thanks for any assistance.

My domain is: N/A

I ran this command:
certbot || certbot --nginx
It produced this output:
Traceback (most recent call last):
File "/usr/bin/certbot", line 6, in
from pkg_resources import load_entry_point
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 3019, in
@_call_aside
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 3003, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 3032, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 646, in _build_master
ws = cls()
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 639, in init
self.add_entry(entry)
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 695, in add_entry
for dist in find_distributions(entry, True):
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 2019, in find_on_path
path_item, entry, metadata, precedence=DEVELOP_DIST
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 2432, in from_location
py_version=py_version, platform=platform, **kw
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 2772, in _reload_version
md_version = _version_from_file(self._get_metadata(self.PKG_INFO))
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 2397, in _version_from_file
line = next(iter(version_lines), '')
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 2565, in _get_metadata
for line in self.get_metadata_lines(name):
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 1467, in get_metadata_lines
return yield_lines(self.get_metadata(name))
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 1464, in get_metadata
return value.decode('utf-8') if six.PY3 else value
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xff in position 0: invalid start byte

My web server is (include version):
Operating System: Raspbian GNU/Linux 9 (stretch)
Kernel: Linux 4.14.79-v7+
Architecture: arm

The operating system my web server runs on is (include version):
Operating System: Raspbian GNU/Linux 9 (stretch)
Kernel: Linux 4.14.79-v7+
Architecture: arm

My hosting provider, if applicable, is:
N/A
I can login to a root shell on my machine (yes or no, or I don't know):
Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
Crashes on certbot --version
Here is the package installed: certbot is already the newest version (0.28.0-1~deb9u3).

Have you tried:
Certbot - Debianstretch Other (eff.org)

Thanks for the suggestion - It appears there was a "janky" stuff going on the with the machine. Was unable to install snap core for a while. I've resolved the issues now & snap installation of certbot has resolved the launch issues.

1 Like