Certbot can't access subdomain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: test.rietdijk.dev

I ran this command: certbot --nginx

It produced this output: Timeout during connect (likely a firewall problem)

My web server is (include version): nginx 1.22.1

The operating system my web server runs on is (include version): EndeavourOS Cassini (Arch 6.1.3)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.32.2

I have a top domain (rietdijk.dev) with a certificate and all is working fine. Now I wanted to add a subdomain and add a cert for that one too. The subdomain is up and with curl I can access the site, but certbot cannot connect to the domain for the acme challenge. It says it's probably a firewall problem, but because I can access the site via curl, I don't know if that's the case.

Welcome to the community @HeadlessHamster

It looks like you have port 80 (http) blocked for both your top domain and test subdomain. I can't reach either one of your domains using HTTP from the public internet. I can reach both using HTTPS although get a warning about the cert for your test domain.

You can see this problem yourself with the Let's Debug test site (link here). Or, use a mobile phone with wifi turned off to use your provider network.


Thanks! I hadn't port forwarded port 80 for my subdomains. Thanks for your answer!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.