Sub domain can not resolve after using certbot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command: sudo certbot --nginx

It produced this output:

It said everything was configured properly. I closed my terminal window at this point, thinking everything was good since I generated plenty of certs for wordpress sites so nginx should be no problem.

Instead I discover the subdomain is now totally inaccessible in both http and https. I even tried to revert to the old configuration settings and it still does not work. I totally regret not just doing sudo certbot certonly --nginx and manually setting it up.

My web server is (include version): nginx version: nginx/1.20.1

The operating system my web server runs on is (include version): Ubuntu 20.4

My hosting provider, if applicable, is: Lightsail

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot 1.20.0

It looks like nginx is not running at all, is the configuration in a state where it can be started?

sudo nginx -t
1 Like

It was. All of my other sub domains worked. But I decided to destroy my cloud instance and start over.


It sounds like you might need to open TCP port 443 in your Lightsail control panel or the instance firewall, or both.

HTTP: port 80
HTTPS: port 443


haha yes that was it! Silly me, I didn't realize an "OS only" instance of Lightsail would have that port closed by default! Thank you for the tip!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.