Certbot auto failed on Wordpress GCP installation


Before the relevant info, here comes what and how I’m trying to achieve.
My company have a website (wordpress), hosted at Google Cloud Platform (Click-to-Deployrunning onBitnami). I need anSSL certificate for it, and tried several methods to get a certificate. Certbot is the latest.

My domain is:

I ran this command:
./certbot-auto certonly -a webroot -w /opt/bitnami/apps/wordpress/htdocs/ -d ihub.org.br -d www.ihub.org.br

It produced this output:


./certbot-auto has insecure permissions!
To learn how to fix them, visit Certbot-auto deployment best practices
Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?

1: Spin up a temporary webserver (standalone)
2: Place files in webroot directory (webroot)

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Plugins selected: Authenticator webroot, Installer None
Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for ihub.org.br
http-01 challenge for www.ihub.org.br
Using the webroot path /opt/bitnami/apps/wordpress for all unmatched domains.
Waiting for verification…
Challenge failed for domain ihub.org.br
Challenge failed for domain www.ihub.org.br
http-01 challenge for ihub.org.br
http-01 challenge for www.ihub.org.br
Cleaning up challenges
Some challenges have failed.


My web server is (include version):
Apache (2.4.34)

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
Google CloudPlatform

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Yes, but most of the operations I perform using SSH (GC sdk, Putty for Windows)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

The A domanin record is correctly set. Checked using:

Thank you for your support.

Hi @n4ndoz

your command is incomplete, add

-a webroot

You see, Certbot ignores the -w parameter and asks. So /opt/bitnami/apps/wordpress is used, not /opt/bitnami/apps/wordpress/htdocs.

That may be the error.

webroot should always work, but Bitnami has a lot of possible webroots.


Tried fixing the command, but to no avail. When I don’t use -a webroot, it asks if I want Standalone or Webroot. But then again, the challenges fail and certbot advises to check Domain Records A/AAAA.

Still no solution, and urgently needing to migrate to https.

Thank you any way, Juergen.

Then your webroot is wrong.

That’s a general problem using Bitnami.

You have to find your correct webroot.

Or use dns-01 validation with --manual to create your first certificate. Then you have 60 - 85 days to find a solution (your correct webroot).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.